summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuldeep Singh Dhaka2016-12-19 13:12:49 +0530
committerKuldeep Singh Dhaka2016-12-20 01:26:04 +0530
commit7b0650e73d9f3f8dd5c5d9bfa3d9b090f3b81072 (patch)
tree51b47a958f7e8b74466442d930417aadffcb1b07
downloadaur-7b0650e73d9f3f8dd5c5d9bfa3d9b090f3b81072.tar.gz
Inital commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD45
-rw-r--r--box0-studio.desktop11
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68d28c1d677f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon Dec 19 19:55:07 UTC 2016
+pkgbase = box0-studio-qt-git
+ pkgdesc = Box0 Studio is the Common Instruments software for Box0
+ pkgver = 142.9a951c1
+ pkgrel = 1
+ url = https://www.madresistor.org/box0
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = fftw
+ depends = libbox0
+ depends = libreplot
+ depends = lmfit
+ depends = muparser
+ depends = qt5-base
+ depends = qt5-svg
+ depends = adwaita-icon-theme
+ provides = box0-studio-qt
+ conflicts = box0-studio-qt
+ replaces = box0-studio-qt
+ source = git+https://gitlab.com/madresistor/box0-studio-qt.git
+ source = box0-studio.desktop
+ md5sums = SKIP
+ md5sums = 6454ffd649c576a16397b7d9522848b0
+
+pkgname = box0-studio-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6af11329795
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Kuldeep Singh Dhaka <kuldeepdhaka9@gmail.com>
+
+pkgname=box0-studio-qt-git
+_pkgname=box0-studio-qt
+pkgver=142.9a951c1
+pkgrel=1
+pkgdesc="Box0 Studio is the Common Instruments software for Box0"
+arch=('i686' 'x86_64')
+url="https://www.madresistor.org/box0"
+license=('GPL')
+provides=(box0-studio-qt)
+conflicts=(box0-studio-qt)
+replaces=(box0-studio-qt)
+source=("git+https://gitlab.com/madresistor/$_pkgname.git" "box0-studio.desktop")
+depends=('fftw' 'libbox0' 'libreplot' 'lmfit' 'muparser' 'qt5-base' 'qt5-svg' 'adwaita-icon-theme')
+makedepends=('cmake' 'git')
+md5sums=('SKIP' "6454ffd649c576a16397b7d9522848b0")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always )"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' -DUSE_MULTI_PROC='TRUE' ..
+ make
+}
+
+package() {
+ #desktop file and icon
+ install -Dm644 $srcdir/$_pkgname/src/res/app_icon/app_icon.png "$pkgdir/usr/share/pixmaps/box0-studio.png"
+ install -Dm644 box0-studio.desktop "$pkgdir/usr/share/applications/box0-studio.desktop"
+
+ make -C "$srcdir/$_pkgname/build" DESTDIR="${pkgdir}" install
+}
diff --git a/box0-studio.desktop b/box0-studio.desktop
new file mode 100644
index 000000000000..ce187f185112
--- /dev/null
+++ b/box0-studio.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Name=Box0 Studio
+GenericName=Box0 Common Instruments
+Exec=box0-studio
+Terminal=false
+Icon=box0-studio
+Type=Application
+Categories=Application;Education;Electronics;Science;
+Comment=Box0 Studio is the Common Instruments software for Box0