summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuldeep Singh Dhaka2016-12-19 13:26:46 +0530
committerKuldeep Singh Dhaka2016-12-20 01:26:11 +0530
commit003fdbf8ff0fd7cff2ee12b25a54794a91c8e28e (patch)
tree0f0d073e62a926f42c8ddaf0b1e47d1f48ec9e79
downloadaur-003fdbf8ff0fd7cff2ee12b25a54794a91c8e28e.tar.gz
Inital commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0034d5085bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Dec 19 19:55:08 UTC 2016
+pkgbase = box0-utils-git
+ pkgdesc = Box0 Shell utilities
+ pkgver = 9.221c11c
+ pkgrel = 1
+ url = https://www.madresistor.org/box0
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = libbox0
+ depends = readline
+ provides = box0-utils
+ conflicts = box0-utils
+ replaces = box0-utils
+ source = git+https://gitlab.com/madresistor/box0-utils.git
+ md5sums = SKIP
+
+pkgname = box0-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f4321cb6504
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Kuldeep Singh Dhaka <kuldeepdhaka9@gmail.com>
+
+pkgname=box0-utils-git
+_pkgname=box0-utils
+pkgver=9.221c11c
+pkgrel=1
+pkgdesc="Box0 Shell utilities"
+arch=('i686' 'x86_64')
+url="https://www.madresistor.org/box0"
+license=('GPL')
+provides=(box0-utils)
+conflicts=(box0-utils)
+replaces=(box0-utils)
+source=("git+https://gitlab.com/madresistor/$_pkgname.git")
+depends=('libbox0' 'readline')
+makedepends=('cmake' 'git')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always )"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+ # We are not building demo examples as they will not be installed
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' ..
+ make
+}
+
+package() {
+ make -C "$srcdir/$_pkgname/build" DESTDIR="${pkgdir}" install
+}