summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart De Vries2021-02-03 13:57:54 +0100
committerBart De Vries2021-02-03 13:57:54 +0100
commita07d95a4fe33bbd8032c423e93e55243c8aa164c (patch)
treef86463f4ce2597e0b83ecf1aed01904b056318f3
downloadaur-a07d95a4fe33bbd8032c423e93e55243c8aa164c.tar.gz
Initial commit of box86, version 0.2.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77736407ba4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = box86
+ pkgdesc = Linux Userspace x86 Emulator with a twist
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/ptitSeb/box86
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ optdepends = gl4es: OpenGL 2 for GLES 2 devices
+ source = box86-0.2.0.tar.gz::https://github.com/ptitSeb/box86/archive/v0.2.0.tar.gz
+ sha256sums = adef16eaad76ce9661007900a4014b11e58b4ca840d0ddfcd13965dc87f8ab9f
+
+pkgname = box86
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..134bae51fecb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Bart De Vries <bart at mogwai dot be>
+
+pkgname=box86
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Linux Userspace x86 Emulator with a twist'
+arch=('armv7h')
+url='https://github.com/ptitSeb/box86'
+license=('MIT')
+depends=('gcc-libs')
+optdepends=('gl4es: OpenGL 2 for GLES 2 devices')
+makedepends=('git' 'cmake')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ptitSeb/box86/archive/v${pkgver}.tar.gz")
+sha256sums=('adef16eaad76ce9661007900a4014b11e58b4ca840d0ddfcd13965dc87f8ab9f')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ cmake -B build -S . \
+ -DARM_DYNAREC=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/build
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+