summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart De Vries2020-10-21 09:16:51 +0200
committerBart De Vries2020-10-21 09:18:46 +0200
commit0b130327a68f698ef75e9fe220659816ccd5395f (patch)
tree525e279b08cfaa5eaf715c9a3256d0143476c39c
parentc5d1974372e5f947764bce8c6a78ca68023e8ce7 (diff)
downloadaur-0b130327a68f698ef75e9fe220659816ccd5395f.tar.gz
Fix path in binfmt configuration; general improvements
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
-rw-r--r--binfmt-install-directory.patch7
3 files changed, 25 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1755e13e27b6..fe07aeafc2ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = box86-git
pkgdesc = Linux Userspace x86 Emulator with a twist
- pkgver = v0.1.2.r294.g9119443c
+ pkgver = v0.1.2.r302.g6c4b047b
pkgrel = 1
url = https://github.com/ptitSeb/box86
arch = armv7h
license = MIT
makedepends = git
+ makedepends = cmake
depends = gcc-libs
- source = git+https://github.com/ptitSeb/box86.git
+ source = git+https://github.com/ptitSeb/box86.git#branch=master
+ source = binfmt-install-directory.patch
sha256sums = SKIP
+ sha256sums = e9738f52f26c23828ea8cdcd3125af3fb773d29348bf94ad86f34c492ad05ca7
pkgname = box86-git
diff --git a/PKGBUILD b/PKGBUILD
index 01d5f1b7df85..60bbc32d7300 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=box86
pkgname=${_pkgname}-git
-pkgver=v0.1.2.r294.g9119443c
+pkgver=v0.1.2.r302.g6c4b047b
pkgrel=1
pkgdesc='Linux Userspace x86 Emulator with a twist'
arch=('armv7h')
@@ -10,9 +10,11 @@ url='https://github.com/ptitSeb/box86'
license=('MIT')
depends=('gcc-libs')
#optdepends=('')
-makedepends=('git')
-source=("git+https://github.com/ptitSeb/box86.git")
-sha256sums=('SKIP')
+makedepends=('git' 'cmake')
+source=("git+https://github.com/ptitSeb/box86.git#branch=master"
+ "binfmt-install-directory.patch")
+sha256sums=('SKIP'
+ 'e9738f52f26c23828ea8cdcd3125af3fb773d29348bf94ad86f34c492ad05ca7')
pkgver() {
cd ${_pkgname}
@@ -21,16 +23,17 @@ pkgver() {
prepare() {
cd ${_pkgname}
- mkdir build
+ patch --forward --strip=1 --input="${srcdir}/binfmt-install-directory.patch"
}
build() {
- cd ${_pkgname}/build
+ cd ${_pkgname}
- cmake .. -DARM_DYNAREC=ON \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -B build -S . \
+ -DARM_DYNAREC=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
}
package() {
diff --git a/binfmt-install-directory.patch b/binfmt-install-directory.patch
new file mode 100644
index 000000000000..f93c49c94b0f
--- /dev/null
+++ b/binfmt-install-directory.patch
@@ -0,0 +1,7 @@
+diff --unified --recursive --text box86-orig/system/box86.conf box86/system/box86.conf
+--- box86-orig/system/box86.conf 2020-10-21 08:11:55.564112235 +0200
++++ box86/system/box86.conf 2020-10-21 08:12:15.399998260 +0200
+@@ -1,2 +1,2 @@
+ # /etc/binfmt.d/box86.conf
+-:x86:M::\x7fELF\x01\x01\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x03\x00:\xff\xff\xff\xff\xff\xff\xff\x00\xff\xff\xff\xff\xff\xff\xff\xff\xfe\xff\xff\xff:/usr/local/bin/box86:
++:x86:M::\x7fELF\x01\x01\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x03\x00:\xff\xff\xff\xff\xff\xff\xff\x00\xff\xff\xff\xff\xff\xff\xff\xff\xfe\xff\xff\xff:/usr/bin/box86: