summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart De Vries2021-02-24 08:38:08 +0100
committerBart De Vries2021-02-24 08:38:08 +0100
commit93dff2a0b4400205fd0ffc47e8f70adbcc3e9963 (patch)
tree04097ed742171f05b2071186884936bfa551a6e8
parent0f977466f67d57343410c63762fc69533dea8151 (diff)
downloadaur-93dff2a0b4400205fd0ffc47e8f70adbcc3e9963.tar.gz
Source docs and license moved to subdir
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 912e66242f63..e8d4a3898cef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = box86-git
pkgdesc = Linux Userspace x86 Emulator with a twist
- pkgver = v0.1.8.r106.ge2df6f6c
+ pkgver = v0.2.0.r117.gb3e984bd
pkgrel = 1
url = https://github.com/ptitSeb/box86
arch = armv7h
diff --git a/PKGBUILD b/PKGBUILD
index 7db2782768cb..742bb7aae2a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=box86
pkgname=${_pkgname}-git
-pkgver=v0.1.8.r106.ge2df6f6c
+pkgver=v0.2.0.r117.gb3e984bd
pkgrel=1
pkgdesc='Linux Userspace x86 Emulator with a twist'
arch=('armv7h')
@@ -17,22 +17,29 @@ source=("git+https://github.com/ptitSeb/box86.git#branch=master")
sha256sums=('SKIP')
pkgver() {
- cd ${_pkgname}
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${_pkgname}
- cmake -B build -S . \
- -DARM_DYNAREC=ON \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr
- make -C build
+ cd ${_pkgname}
+ cmake -B build -S . \
+ -DARM_DYNAREC=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
}
package() {
- cd ${_pkgname}/build
- make DESTDIR=${pkgdir} install
- install -Dm644 ../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ cd ${_pkgname}/build
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ../docs/LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}/"
+
+ # Install documentation
+ install -d "${pkgdir}/usr/share/doc/${_pkgname}/"
+ cp -R ../docs/* "${pkgdir}/usr/share/doc/${_pkgname}/"
+
+ find "${pkgdir}"/usr/share/doc/${_pkgname} -type f -exec chmod 0644 {} \;
+ find "${pkgdir}"/usr/share/doc/${_pkgname} -type d -exec chmod 0755 {} \;
}