summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart De Vries2020-10-18 16:54:15 +0200
committerBart De Vries2020-10-18 16:54:15 +0200
commitc5d1974372e5f947764bce8c6a78ca68023e8ce7 (patch)
tree3de5ff41f47ac2461cf30a4d0ac42f999be836a1
downloadaur-c5d1974372e5f947764bce8c6a78ca68023e8ce7.tar.gz
Initial version of box86-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1755e13e27b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = box86-git
+ pkgdesc = Linux Userspace x86 Emulator with a twist
+ pkgver = v0.1.2.r294.g9119443c
+ pkgrel = 1
+ url = https://github.com/ptitSeb/box86
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ depends = gcc-libs
+ source = git+https://github.com/ptitSeb/box86.git
+ sha256sums = SKIP
+
+pkgname = box86-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01d5f1b7df85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Bart De Vries <bart at mogwai dot be>
+
+_pkgname=box86
+pkgname=${_pkgname}-git
+pkgver=v0.1.2.r294.g9119443c
+pkgrel=1
+pkgdesc='Linux Userspace x86 Emulator with a twist'
+arch=('armv7h')
+url='https://github.com/ptitSeb/box86'
+license=('MIT')
+depends=('gcc-libs')
+#optdepends=('')
+makedepends=('git')
+source=("git+https://github.com/ptitSeb/box86.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${_pkgname}
+ mkdir build
+}
+
+build() {
+ cd ${_pkgname}/build
+
+ cmake .. -DARM_DYNAREC=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd ${_pkgname}/build
+
+ make DESTDIR=${pkgdir} install
+
+ install -Dm644 ../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+