summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2015-08-24 21:20:53 -0400
committerbrent s2015-08-24 21:20:53 -0400
commit7951e659b551432992e86e1ad3abf639e2992d14 (patch)
treee966e2d32c6dd02167baf7d8c4439b6c309ae111
downloadaur-7951e659b551432992e86e1ad3abf639e2992d14.tar.gz
initial import from AUR3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--bbserver36
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2828c29fb595
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = boxbackup-server
+ pkgdesc = An open source, completely automatic on-line backup system for UNIX.
+ pkgver = 0.11.1
+ pkgrel = 0
+ url = http://boxbackup.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = openssl
+ depends = perl
+ depends = zlib
+ backup = etc/boxbackup/bbstored.conf
+ source = http://www.boxbackup.org/svn/box/packages/boxbackup-0.11.1.tgz
+ source = bbserver
+ md5sums = c4c4786a918a9c026f80833614c40a6b
+ md5sums = 7a85ba0caf36febfb8e6871c45aa108e
+
+pkgname = boxbackup-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8c29611afca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Andreas Schrafl <aschrafl@jetnet.ch>
+# based on the work of Jaroslav Lichtblau <tu@dragonlord.cz>
+# based on the work of KyAnh, http://kyanh.net/ <xkyanh@gmail.com>
+
+pkgname=boxbackup-server
+pkgver=0.11.1
+pkgrel=0
+pkgdesc="An open source, completely automatic on-line backup system for UNIX."
+arch=('i686' 'x86_64')
+url="http://boxbackup.org"
+license=('BSD')
+depends=('openssl' 'perl' 'zlib')
+backup=('etc/boxbackup/bbstored.conf')
+source=(http://www.boxbackup.org/svn/box/packages/boxbackup-${pkgver}.tgz bbserver)
+
+md5sums=('c4c4786a918a9c026f80833614c40a6b'
+ '7a85ba0caf36febfb8e6871c45aa108e')
+
+build() {
+ cd ${srcdir}/boxbackup-${pkgver}
+
+ ./configure
+
+ make -j1 build-backup-server
+
+ cp ${srcdir}/boxbackup-${pkgver}/release/bin/bbstored/bbstored ${srcdir}/boxbackup-${pkgver}/parcels/boxbackup-${pkgver}-backup-server-linux-gnu/bbstored
+ cp ${srcdir}/boxbackup-${pkgver}/release/bin/bbstoreaccounts/bbstoreaccounts ${srcdir}/boxbackup-${pkgver}/parcels/boxbackup-${pkgver}-backup-server-linux-gnu/bbstoreaccounts
+
+ for f in \
+ bbstored \
+ bbstoreaccounts \
+ bbstored-certs \
+ bbstored-config \
+ raidfile-config ;\
+ do
+ install -D -m755 \
+ ${srcdir}/boxbackup-$pkgver/parcels/boxbackup-$pkgver-backup-server-linux-gnu/$f \
+ ${pkgdir}/usr/bin/$f
+ done
+
+ install -D -m755 "${srcdir}/bbserver" "${pkgdir}/etc/rc.d/bbserver"
+}
diff --git a/bbserver b/bbserver
new file mode 100644
index 000000000000..0a0ac94f1791
--- /dev/null
+++ b/bbserver
@@ -0,0 +1,36 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/bin/bbstored`
+case "$1" in
+ start)
+ stat_busy "Starting BoxBackup Server"
+ [ -z "$PID" ] && /usr/bin/bbstored
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon bbserver
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping BoxBackup Server"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon bbserver
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0