summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Woudstra2023-04-18 13:26:36 +0200
committerEric Woudstra2023-04-18 13:26:36 +0200
commita8f52bbdea7c8495526df13cee0b3b84c7ff0e3a (patch)
tree44e7c44f0cd7b163d17303c849ba7daf29937795
parent29fbace1ee98d37927aad4a196a099d54c61af70 (diff)
downloadaur-a8f52bbdea7c8495526df13cee0b3b84c7ff0e3a.tar.gz
fat32 clustersize 8k
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xbpir-writefip4
3 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4cad4a28528..a52fd7e65503 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bpir64-atf-git
pkgdesc = ATF BPI-R64 & BPI-R3 images including fiptool
- pkgver = v2.8r12166.47fd2bb22
- pkgrel = 5
+ pkgver = v2.8r12169.30aa84c97
+ pkgrel = 1
epoch = 2
url = https://github.com/mtk-openwrt/arm-trusted-firmware.git
install = bpir64-atf-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 0ad793bb7c16..551852fbcedd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@ _gitbranch="bpir"
#_gitbranch="mtksoc"
pkgname=bpir64-atf-git
epoch=2
-pkgver=v2.8r12166.47fd2bb22
-pkgrel=5
+pkgver=v2.8r12169.30aa84c97
+pkgrel=1
pkgdesc='ATF BPI-R64 & BPI-R3 images including fiptool'
_ubootpkgver=2023.01
url='https://github.com/mtk-openwrt/arm-trusted-firmware.git'
diff --git a/bpir-writefip b/bpir-writefip
index 22cf2560625c..b03dfcf01cc9 100755
--- a/bpir-writefip
+++ b/bpir-writefip
@@ -44,7 +44,6 @@ fstabstr="PARTLABEL=${target}-${atfdevice}-boot"
#######################
# Convert FIP to BOOT #
#######################
-##### DEZE NOG CHECK!
if [[ $@ =~ "--fip2boot" ]] && [ -L ${fipdevicel} ]; then
set -e
pkfip=$(lsblk -rno pkname ${fipdevicel})
@@ -54,7 +53,7 @@ if [[ $@ =~ "--fip2boot" ]] && [ -L ${fipdevicel} ]; then
echo "Moving files from /boot to $tmp/boot"
mv -fT /boot $tmp/boot
parted -s -- "/dev/$pkfip" name $nrfip ${target}-${atfdevice}-boot
- mkfs.vfat -F 32 -n "${target^^}-BOOT" ${bootdevicel}
+ mkfs.vfat -v -F 32 -S 512 -s 16 -n "${target^^}-BOOT" ${bootdevicel}
mkdir /boot
mount -t vfat ${bootdevicel} /boot
echo "Copying files from $tmp/boot to /boot"
@@ -69,7 +68,6 @@ fi
#######################
# Convert BOOT to FIP #
#######################
-##### DEZE NOG CHECK!
if [[ $@ =~ "--boot2fip" ]] && [ -L ${bootdevicel} ]; then
set -e
pkfip=$(lsblk -rno pkname ${bootdevicel})