summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Woudstra2022-12-02 08:37:52 +0100
committerEric Woudstra2022-12-02 08:37:52 +0100
commit86d8058d05e969417cd26d5bb5b12b173bb9c3ef (patch)
tree5fb54deb87b06a0b655d6f3309a396ea5db6a8f7
parent2db9b2050e61460f492858e1afd6848c5264680b (diff)
downloadaur-86d8058d05e969417cd26d5bb5b12b173bb9c3ef.tar.gz
Remove dependancy on openssl
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef976417b5d1..3ae796bcbbc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bpir64-mkimage
pkgdesc = Mkimage tool modified to stretch the image leaving empty space on sectors 2 through 34, so a GPT table can be used without problems.
pkgver = 2021.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/u-boot/u-boot
arch = aarch64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index a8b7680d636b..f7b371312c72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Eric Woudstra <ericwouds@gmail.com>
pkgname=bpir64-mkimage
pkgver=2021.10
-pkgrel=1
+pkgrel=2
pkgdesc='Mkimage tool modified to stretch the image leaving empty space on sectors 2 through 34, so a GPT table can be used without problems.'
arch=(aarch64)
url='https://github.com/u-boot/u-boot'
@@ -17,7 +17,13 @@ build() {
cd "${srcdir}/u-boot-${pkgver}"
patch -p1 -N -r - < "${srcdir}/mtkimage-buffer-inc.patch"
patch -p1 -N -r - < "${srcdir}/mtkimage-gpt-expand.patch"
- ARCH=arm64 make mt7622_rfb_defconfig tools-only
+ cp -vf configs/mt7622_rfb_defconfig configs/my_defconfig
+ # No libcrypto (openssl)
+ echo "CONFIG_TOOLS_LIBCRYPTO=n" | tee -a configs/my_defconfig
+ # kwbimage needs libcrypto, so remove it from build
+ sed -i '/kwbimage.o \\/d' ./tools/Makefile
+ ARCH=arm64 make my_defconfig
+ ARCH=arm64 make tools-only
cp -vf tools/mkimage tools/bpir64-mkimage
}