summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Verri2017-08-21 10:47:52 -0300
committerFilipe Verri2017-08-21 10:47:52 -0300
commit05a6e3208786b1c696fce0bec578e1e6f2262852 (patch)
treefcc37046b19b9e61dd1da16d18efc7a710b16f9c
parent065703b4e02b4072c7b1674c1671b4f8ce5451aa (diff)
downloadaur-05a6e3208786b1c696fce0bec578e1e6f2262852.tar.gz
Recompile b-boot only if needed.
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4649eaeb5beb..6b726a692ec6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,9 @@ build() {
if test -z "$(command -v b && b --version | grep '^build2 0.6.0')"
then
cd build2
- ./bootstrap.sh g++
+ if ! test -x build2/b-boot; then
+ ./bootstrap.sh g++
+ fi
cd ..
export BCMD="$(pwd)/build2/build2/b-boot"
else