summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Muvirimi2022-07-15 14:13:44 +0200
committerRichard Muvirimi2022-07-15 14:22:40 +0200
commitff67a3e02653a67f24dcb66be7c41c0e562c8adb (patch)
treeb27815388305c1c23a559fc981ea0a6cdb4dd405
parent5458a459add7d9a10c44af5779f23fd07293488b (diff)
downloadaur-bpkg-git.tar.gz
Release 1.1.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75c8e05aaf8a..6b9007e64274 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bpkg-git
pkgdesc = Lightweight bash package manager
- pkgver = 0.3.1.7.g707863e
+ pkgver = 1.1.3.bd8c92f
pkgrel = 1
url = http://www.bpkg.sh/
arch = any
@@ -9,7 +9,7 @@ pkgbase = bpkg-git
depends = bash
provides = bpkg
conflicts = bpkg
- source = git+https://github.com/bpkg/bpkg
+ source = bpkg::git+https://github.com/bpkg/bpkg
md5sums = SKIP
pkgname = bpkg-git
diff --git a/PKGBUILD b/PKGBUILD
index 199c71466e5b..d00dcb6d380f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: scrouthtv <scrouthtv 0x40 gmail 0x2e com>
+# Maintainer: richard-muvirimi <tygalive at gmail dot com>
+# Contributor: scrouthtv <scrouthtv 0x40 gmail 0x2e com>
# Contributor: Marcos Ferreira <merkkp at gmail dot com>
_gitname="bpkg"
+
pkgname="${_gitname}-git"
-pkgver=0.3.1.7.g707863e
+pkgver=1.1.3.bd8c92f
pkgrel=1
pkgdesc="Lightweight bash package manager"
arch=("any")
@@ -13,16 +15,30 @@ depends=("bash")
makedepends=("git")
provides=("${_gitname}")
conflicts=("${_gitname}")
-source=("git+https://github.com/bpkg/${_gitname}")
+source=("${_gitname}::git+https://github.com/${_gitname}/${_gitname}")
md5sums=("SKIP")
pkgver() {
cd "${_gitname}"
- git describe --tags --long | sed 's/^v//;s/-/./;s/-/./g'
+
+ TAG="$(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/-/.r/;s/-/./')"
+ HASH="$(git describe --tags --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+
+ # Outputs something like: 1.1.3.bd8c92f
+ echo "$TAG.$HASH"
+}
+
+build(){
+ cd "${srcdir}/${_gitname}"
+
+ # Check out latest tag
+ git fetch --tags
+ git checkout "$(git describe --tags $(git rev-list --tags --max-count=1))"
}
package() {
cd "${srcdir}/${_gitname}"
+
PREFIX="${pkgdir}/usr" ./setup.sh
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}