summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Ferreira2016-10-15 10:05:12 -0300
committerMarcos Ferreira2016-10-15 10:05:12 -0300
commit15a46e1fca627dadb837a8adaac04a9fc981f681 (patch)
treee38af99c62ba401f26e0956e25cc209ae055791a
downloadaur-15a46e1fca627dadb837a8adaac04a9fc981f681.tar.gz
first pkgbuild for bpkg.io
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c505e7ce201c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bpkg-git
+ pkgdesc = Lightweight bash package manager
+ pkgver = 0.2.8.21.gc1f0cd3
+ pkgrel = 1
+ url = https://bpkg.io
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = bash
+ provides = bpkg
+ conflicts = bpkg
+ source = git+https://github.com/bpkg/bpkg
+ md5sums = SKIP
+
+pkgname = bpkg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a01b5dc87ff0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marcos Ferreira <merkkp at gmail dot com>
+
+_gitname="bpkg"
+pkgname="${_gitname}-git"
+pkgver=0.2.8.21.gc1f0cd3
+pkgrel=1
+pkgdesc="Lightweight bash package manager"
+arch=("any")
+url="https://bpkg.io"
+license=("MIT")
+depends=("bash")
+makedepends=("git")
+provides=("${_gitname}")
+conflicts=("${_gitname}")
+source=("git+https://github.com/bpkg/${_gitname}")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --tags --long | sed 's/^v//;s/-/./;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ PREFIX="${pkgdir}/usr" ./setup.sh
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: