summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordesbma2017-04-23 22:44:20 +0200
committerdesbma2017-04-23 22:44:20 +0200
commit74919b43750c9b60e2fb0d5c131a8516d809c573 (patch)
tree4f9402da64eea4dbcff37c0d14f1e7d4155cf4ea
downloadaur-74919b43750c9b60e2fb0d5c131a8516d809c573.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD32
-rw-r--r--fix-bpm-graph-man.patch5
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0a87d0517e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bpm-tools
+ pkgdesc = Tools to calculate tempo of audio tracks, display graphs and tag files with bpm value
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://www.pogo.org.uk/~mark/bpm-tools/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sox
+ optdepends = gnuplot: for bpm-graph usage
+ optdepends = flac: flac tagging support for bpm-tag
+ optdepends = vorbis-tools: vorbis tagging support for bpm-tag
+ optdepends = id3v2: MP3 tagging support for bpm-tag
+ source = http://www.pogo.org.uk/~mark/bpm-tools/releases/bpm-tools-0.3.tar.gz
+ source = fix-bpm-graph-man.patch
+ sha512sums = 7d01bea3689b7ed57063620d71a4a70709d64abddfeddde851da90b4ae585427fd7fcc41b46a3677ef9c6ad7109c58523696cf2f3d4a5c0198727e6428a9fc10
+ sha512sums = d43fa663366a1e3254bb4d20918d61676971562525945083183af3ebf27551f550efe63e2d79f4f9649e98db8a422552db5c529bdb29865ab3827312d88408bf
+
+pkgname = bpm-tools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..293d7af4d34a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.pkg.tar.xz
+/bpm-tools*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f3a168d8f85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: desbma
+pkgname=bpm-tools
+pkgver=0.3
+pkgrel=1
+pkgdesc="Tools to calculate tempo of audio tracks, display graphs and tag files with bpm value"
+arch=('i686' 'x86_64')
+url="http://www.pogo.org.uk/~mark/bpm-tools/"
+license=('GPL2')
+depends=('sox')
+optdepends=('gnuplot: for bpm-graph usage'
+ 'flac: flac tagging support for bpm-tag'
+ 'vorbis-tools: vorbis tagging support for bpm-tag'
+ 'id3v2: MP3 tagging support for bpm-tag')
+source=(http://www.pogo.org.uk/~mark/bpm-tools/releases/${pkgname}-${pkgver}.tar.gz
+ 'fix-bpm-graph-man.patch')
+sha512sums=('7d01bea3689b7ed57063620d71a4a70709d64abddfeddde851da90b4ae585427fd7fcc41b46a3677ef9c6ad7109c58523696cf2f3d4a5c0198727e6428a9fc10'
+ 'd43fa663366a1e3254bb4d20918d61676971562525945083183af3ebf27551f550efe63e2d79f4f9649e98db8a422552db5c529bdb29865ab3827312d88408bf')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -i "${srcdir}/fix-bpm-graph-man.patch" bpm-graph.1
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
diff --git a/fix-bpm-graph-man.patch b/fix-bpm-graph-man.patch
new file mode 100644
index 000000000000..b550773b3ec7
--- /dev/null
+++ b/fix-bpm-graph-man.patch
@@ -0,0 +1,5 @@
+--- bpm-graph.1.orig 2013-05-21 22:38:33.000000000 +0200
++++ bpm-graph.1 2017-04-23 22:37:33.859750046 +0200
+@@ -1 +1 @@
+-.so man1/bpm-graph.1
++.so man1/bpm.1