summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2017-07-17 20:20:45 +0800
committerJingbei Li2017-07-17 20:20:45 +0800
commit111469191966e32279de397cee02547125f3d0d0 (patch)
treec228cb85023bee9d1d2cde73987c954682ad7586
parenta87ed02561a9f4aaf21d006c55f64a78a5358f2d (diff)
downloadaur-111469191966e32279de397cee02547125f3d0d0.tar.gz
use g++-5 to solve icu ABI issues
-rw-r--r--.SRCINFO5
-rwxr-xr-xPKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f9e9c03c631..972005a7d30d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jul 11 12:22:43 UTC 2017
+# Mon Jul 17 12:20:39 UTC 2017
pkgbase = brackets
pkgdesc = An open source code editor for the web, written in JavaScript, HTML and CSS. Stable git Tags.
pkgver = 1.10
- pkgrel = 1
+ pkgrel = 2
url = http://brackets.io
install = brackets.install
arch = i686
@@ -14,6 +14,7 @@ pkgbase = brackets
makedepends = gtk2
makedepends = python2
makedepends = npm
+ makedepends = gcc5
depends = alsa-lib
depends = nodejs
depends = npm
diff --git a/PKGBUILD b/PKGBUILD
index a66715ad94be..99e797d817c6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=brackets
pkgver=1.10
-pkgrel=1
+pkgrel=2
pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS. Stable git Tags."
arch=('i686' 'x86_64')
url="http://brackets.io"
@@ -16,7 +16,7 @@ optdepends=(
"hicolor-icon-theme: for hicolor theme hierarchy"
)
conflicts=("brackets-git" "brackets-bin")
-makedepends=('git' 'unzip' 'gtk2' 'python2' 'npm')
+makedepends=('git' 'unzip' 'gtk2' 'python2' 'npm' 'gcc5')
install=${pkgname}.install
source=("git+https://github.com/adobe/brackets-shell.git#branch=linux-1547"
#"git+https://github.com/adobe/brackets-shell.git#tag=release-${pkgver}"
@@ -40,10 +40,8 @@ build() {
npm install
##### environment cleaning due to branch switch ####
rm -rf out
- node_modules/grunt-cli/bin/grunt cef-clean
- ####################################################
node_modules/grunt-cli/bin/grunt setup
- make
+ LINK=g++-5 make
}
package() {