summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2018-05-14 01:08:55 +0800
committerJingbei Li2018-05-14 01:08:55 +0800
commit368faf8b020c29e8a53f712a8b43dd01720184b0 (patch)
tree467ad3ce2ec6b62934a38cc621d53d5cd5227deb
parent27d8d07b94cc12a1697ab144f5dcce6f20875b22 (diff)
downloadaur-368faf8b020c29e8a53f712a8b43dd01720184b0.tar.gz
use it's own node rather than system node
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ec72493e1e9..c52c1cf3c560 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Feb 5 09:39:54 UTC 2018
pkgbase = brackets
pkgdesc = An open source code editor for the web, written in JavaScript, HTML and CSS.
pkgver = 1.12
- pkgrel = 2
+ pkgrel = 3
url = http://brackets.io
install = brackets.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 838c6d51a410..b63965ce1267 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=brackets
pkgver=1.12
-pkgrel=2
+pkgrel=3
pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS."
arch=('i686' 'x86_64')
url="http://brackets.io"
@@ -29,11 +29,6 @@ prepare() {
}
build() {
- cd ${srcdir}/brackets
- npm install
- sed "/'npm-install',$/d" -i Gruntfile.js
- node_modules/grunt-cli/bin/grunt build
-
cd ${srcdir}/brackets-shell
sed -i 's/python/python2/' gyp/gyp
npm install
@@ -42,6 +37,11 @@ build() {
node_modules/grunt-cli/bin/grunt cef icu node create-project
#use g++-5 to solve icu ABI issue
LINK=g++-5 make
+
+ cd ${srcdir}/brackets
+ npm install
+ sed "/'npm-install',$/d" -i Gruntfile.js
+ ../brackets-shell/deps/node/bin/Brackets-node node_modules/grunt-cli/bin/grunt build
}
package() {