summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2017-03-25 17:25:33 +0800
committerJingbei Li2017-03-25 17:25:33 +0800
commit790afb47e2c11207399edf44b6d1cd20de12c1f9 (patch)
tree73f4b8895e0bdb7f56ff77178721829d62b0cd6e
parent9bb282e37328212cd927cb28963d8af00dc0e7b4 (diff)
downloadaur-790afb47e2c11207399edf44b6d1cd20de12c1f9.tar.gz
Try to updated it to 1.9
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rwxr-xr-xPKGBUILD8
3 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index feebef8ef5e2..63e3cd041c01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Mar 25 09:25:28 UTC 2017
pkgbase = brackets
pkgdesc = An open source code editor for the web, written in JavaScript, HTML and CSS. Stable git Tags.
- pkgver = 1.8
+ pkgver = 1.9
pkgrel = 1
url = http://brackets.io
install = brackets.install
@@ -10,6 +12,7 @@ pkgbase = brackets
makedepends = git
makedepends = unzip
makedepends = gyp-git
+ makedepends = gtk2
depends = alsa-lib
depends = nodejs
depends = npm
@@ -17,6 +20,7 @@ pkgbase = brackets
depends = gconf
depends = libgcrypt15
depends = libudev0
+ depends = nss
optdepends = google-chrome: to enable Live Preview
optdepends = gnuplot: to enable node benchmarking
optdepends = gtk2: to enable native UI
@@ -25,7 +29,7 @@ pkgbase = brackets
conflicts = brackets-git
conflicts = brackets-bin
source = brackets-shell::git+https://github.com/adobe/brackets-shell.git#branch=linux-1547
- source = brackets::git+https://github.com/adobe/brackets.git#tag=release-1.8
+ source = brackets::git+https://github.com/adobe/brackets.git#tag=release-1.9
md5sums = SKIP
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..355164c12651
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*/
diff --git a/PKGBUILD b/PKGBUILD
index e36e30eed579..5809ba5bc9f0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: 4javier <4javiereg4 _ at _ gmail _ dot _com>
pkgname=brackets
-pkgver=1.8
+pkgver=1.9
pkgrel=1
pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS. Stable git Tags."
arch=('i686' 'x86_64')
url="http://brackets.io"
license=('MIT')
-depends=(alsa-lib nodejs npm desktop-file-utils gconf libgcrypt15 libudev0)
+depends=(alsa-lib nodejs npm desktop-file-utils gconf libgcrypt15 libudev0 nss)
optdepends=(
"google-chrome: to enable Live Preview"
"gnuplot: to enable node benchmarking"
@@ -16,10 +16,10 @@ optdepends=(
"hicolor-icon-theme: for hicolor theme hierarchy"
)
conflicts=("brackets-git" "brackets-bin")
-makedepends=('git' 'unzip' 'gyp-git')
+makedepends=('git' 'unzip' 'gyp-git' 'gtk2')
install=${pkgname}.install
source=("brackets-shell::git+https://github.com/adobe/brackets-shell.git#branch=linux-1547"
- #"brackets-shell::git+https://github.com/adobe/brackets-shell.git#tag=release-${pkgver}"
+ #"brackets-shell::git+https://github.com/adobe/brackets-shell.git#tag=release-${pkgver}"
"${pkgname}::git+https://github.com/adobe/brackets.git#tag=release-${pkgver}")
md5sums=('SKIP' 'SKIP')