summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2017-04-25 12:15:35 +0800
committerJingbei Li2017-04-25 12:15:35 +0800
commitbe12f519d122f7346ab3a6d8b77e68fa0f3ad89b (patch)
tree058bff5727756534a5376f7c8bdeffd059f22b08
parentdc67a0a6faf6a02985d6a06e7da30be3e5fb814b (diff)
downloadaur-be12f519d122f7346ab3a6d8b77e68fa0f3ad89b.tar.gz
added CodeMirror
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rwxr-xr-xPKGBUILD19
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 908357ac64bb..8a4360ca9c6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Apr 25 03:30:27 UTC 2017
+# Tue Apr 25 04:15:32 UTC 2017
pkgbase = brackets
pkgdesc = An open source code editor for the web, written in JavaScript, HTML and CSS. Stable git Tags.
pkgver = 1.9
- pkgrel = 2
+ pkgrel = 3
url = http://brackets.io
install = brackets.install
arch = i686
@@ -27,8 +27,8 @@ pkgbase = brackets
optdepends = hicolor-icon-theme: for hicolor theme hierarchy
conflicts = brackets-git
conflicts = brackets-bin
- source = brackets-shell::git+https://github.com/adobe/brackets-shell.git#branch=linux-1547
- source = brackets::git+https://github.com/adobe/brackets.git#tag=release-1.9
+ source = git+https://github.com/adobe/brackets-shell.git#branch=linux-1547
+ source = git+https://github.com/adobe/brackets.git#tag=release-1.9
md5sums = SKIP
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
index 355164c12651..d1fce8211b45 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
*/
+*.pkg*
+*.sw*
diff --git a/PKGBUILD b/PKGBUILD
index 2ffdf4f6d6e8..ce6962f2a84f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: 4javier <4javiereg4 _ at _ gmail _ dot _com>
+# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=brackets
pkgver=1.9
-pkgrel=2
+pkgrel=3
pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS. Stable git Tags."
arch=('i686' 'x86_64')
url="http://brackets.io"
@@ -18,9 +18,10 @@ optdepends=(
conflicts=("brackets-git" "brackets-bin")
makedepends=('git' 'unzip' 'gtk2')
install=${pkgname}.install
-source=("brackets-shell::git+https://github.com/adobe/brackets-shell.git#branch=linux-1547"
+source=("git+https://github.com/adobe/brackets-shell.git#branch=linux-1547"
#"brackets-shell::git+https://github.com/adobe/brackets-shell.git#tag=release-${pkgver}"
- "${pkgname}::git+https://github.com/adobe/brackets.git#tag=release-${pkgver}")
+ "git+https://github.com/adobe/brackets.git#tag=release-${pkgver}"
+)
md5sums=('SKIP' 'SKIP')
@@ -30,6 +31,10 @@ prepare() {
}
build() {
+ cd ${srcdir}/brackets
+ npm install
+ node_modules/grunt-cli/bin/grunt build
+
cd ${srcdir}/brackets-shell
sed -i 's/python/python2/' gyp/gyp
npm install
@@ -43,7 +48,7 @@ build() {
package() {
cd ${srcdir}/brackets-shell
-
+
install -dm755 "${pkgdir}/opt/brackets"
cp -R out/Release/lib "${pkgdir}/opt/brackets/lib"
cp -R out/Release/locales "${pkgdir}/opt/brackets/locales"
@@ -66,10 +71,12 @@ package() {
for size in 32 48 128 256; do
install -Dm644 "out/Release/appshell${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/brackets.png"
done
-
+
cd ${srcdir}/${pkgname}
# Copy samples
cp -R "samples" "${pkgdir}/opt/brackets/samples"
# Copy www
cp -R "src" "${pkgdir}/opt/brackets/www"
+
+ cp -r $srcdir/brackets/src/thirdparty/CodeMirror $pkgdir/opt/brackets/www/thirdparty
}