summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2019-04-20 04:17:41 +0800
committerJingbei Li2019-04-20 04:17:41 +0800
commite29c3c649da83987a64b125680640756100129d0 (patch)
treed588d0d6244c8b2b8b68bea5b0007e993312a574
parentc425cedcf3c48ef7de6a840f83e84aef07e3b0d5 (diff)
downloadaur-e29c3c649da83987a64b125680640756100129d0.tar.gz
fixed 1.13
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD66
3 files changed, 75 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb4608ef5219..996aa0bd33ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = brackets
pkgdesc = An open source code editor for the web, written in JavaScript, HTML and CSS.
pkgver = 1.13
- pkgrel = 1
+ pkgrel = 2
url = http://brackets.io
install = brackets.install
- arch = i686
arch = x86_64
license = MIT
- makedepends = gcc5
makedepends = git
makedepends = gtk2
makedepends = python2
@@ -30,10 +28,26 @@ pkgbase = brackets
optdepends = hicolor-icon-theme: for hicolor theme hierarchy
conflicts = brackets-git
conflicts = brackets-bin
+ noextract = cef_binary_3.2785.1486_linux64_release.zip
+ noextract = node-v6.11.0-linux-x64.tar.gz
source = git+https://github.com/adobe/brackets#tag=release-1.13
- source = git+https://github.com/adobe/brackets-shell#tag=release-1.13
+ source = git+https://github.com/adobe/brackets-shell#tag=release-1.12
+ source = jslint::git+https://github.com/peterflynn/JSLint
+ source = git+https://github.com/jrburke/requirejs
+ source = mustache::git+https://github.com/janl/mustache.js
+ source = https://patch-diff.githubusercontent.com/raw/adobe/brackets-shell/pull/648.patch
+ source = http://s3.amazonaws.com/files.brackets.io/cef/cef_binary_3.2785.1486_linux64_release.zip
+ source = http://nodejs.org/dist/v6.11.0/node-v6.11.0-linux-x64.tar.gz
+ source = https://github.com/adobe/brackets/releases/download/release-1.13/Brackets.Release.1.13.64-bit.deb
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 4421e27e2e333a14b9f1dd3bea4248a6
+ md5sums = 9b1364b60786a595076f9da789512685
+ md5sums = e6ade07945c32f82da184ebbcb5347dc
+ md5sums = b0a9869cf421970ecaeaf7aa180ec008
pkgname = brackets
diff --git a/.gitignore b/.gitignore
index de722566e70e..57126a8be38e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,8 @@
*/
*.pkg*
*.sw*
+*.zip
+*.tar*
*.log
+*.patch
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
index 3565ddf323cc..b0c7c841cb14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=brackets
pkgver=1.13
-pkgrel=1
+pkgrel=2
+_cef_ver=3.2785.1486
+_node_ver=6.11.0
pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://brackets.io"
license=('MIT')
depends=(alsa-lib desktop-file-utils gconf libgcrypt15 libudev0-shim libxss libxtst nodejs npm nss pango)
@@ -15,28 +17,65 @@ optdepends=(
"hicolor-icon-theme: for hicolor theme hierarchy"
)
conflicts=("brackets-git" "brackets-bin")
-makedepends=('gcc5' 'git' 'gtk2' 'python2' 'unzip')
+makedepends=('git' 'gtk2' 'python2' 'unzip')
install=${pkgname}.install
-source=("git+https://github.com/adobe/brackets#tag=release-${pkgver}"
- "git+https://github.com/adobe/brackets-shell#tag=release-${pkgver}"
- #"git+https://github.com/adobe/brackets-shell#branch=linux-1547"
+source=("git+https://github.com/adobe/brackets#tag=release-${pkgver//_/-}"
+ #"git+https://github.com/adobe/brackets-shell#tag=release-${pkgver//_/-}"
+ "git+https://github.com/adobe/brackets-shell#tag=release-1.12"
+ "jslint::git+https://github.com/peterflynn/JSLint"
+ "git+https://github.com/jrburke/requirejs"
+ "mustache::git+https://github.com/janl/mustache.js"
+ 'https://patch-diff.githubusercontent.com/raw/adobe/brackets-shell/pull/648.patch'
+ "http://s3.amazonaws.com/files.brackets.io/cef/cef_binary_${_cef_ver}_linux64_release.zip"
+ "http://nodejs.org/dist/v${_node_ver}/node-v${_node_ver}-linux-x64.tar.gz"
+ "https://github.com/adobe/brackets/releases/download/release-${pkgver}/Brackets.Release.${pkgver}.64-bit.deb"
)
-md5sums=('SKIP' 'SKIP')
+noextract=("cef_binary_${_cef_ver}_linux64_release.zip" "node-v${_node_ver}-linux-x64.tar.gz")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '4421e27e2e333a14b9f1dd3bea4248a6'
+ '9b1364b60786a595076f9da789512685'
+ 'e6ade07945c32f82da184ebbcb5347dc'
+ 'b0a9869cf421970ecaeaf7aa180ec008')
prepare() {
+ tar -xf data.tar.xz
+
cd ${srcdir}/${pkgname}
+ git config submodule.src/extensions/default/JSLint/thirdparty/jslint.url "$srcdir/jslint"
+ for i in mustache requirejs
+ do
+ git config submodule.src/thirdparty/${i}.url "$srcdir/$i"
+ done
git submodule update --init --recursive
+
+ cd ${srcdir}/brackets-shell
+ sed 's/python/python2/' -i gyp/gyp
+ sed 's/UnicodeString/icu::UnicodeString/g' -i appshell/appshell_extensions_platform.cpp
+ sed '29i\#include <unicode/ucnv.h>' -i appshell/appshell_extensions_platform.h
+ sed '29i\#include <unicode/unistr.h>' -i appshell/appshell_extensions_platform.h
+ patch -Np1 < $srcdir/648.patch
+
+ mkdir -p downloads
+ ln -sf ${srcdir}/cef_binary_${_cef_ver}_linux64_release.zip downloads
+ ln -sf ${srcdir}/node-v${_node_ver}-linux-x64.tar.gz downloads
}
build() {
cd ${srcdir}/brackets-shell
- sed -i 's/python/python2/' gyp/gyp
npm install
- #environment cleaning due to branch switch
rm -rf out
- node_modules/grunt-cli/bin/grunt cef icu node create-project
- #use g++-5 to solve icu ABI issue
- LINK=g++-5 make
+ node_modules/grunt-cli/bin/grunt cef node create-project
+
+ # I hate static libs.
+ sed 's|deps/icu/lib/\(.*\)\.a|/usr/lib/\1.so|g' -i Brackets.target.mk
+
+ # Building
+ cd ${srcdir}/brackets-shell
+ make
cd ${srcdir}/brackets
npm install
@@ -62,10 +101,11 @@ package() {
cp -R {files,locales,node-core} "${pkgdir}/opt/brackets/"
find . -maxdepth 1 -type f -exec \
cp {} ${pkgdir}/opt/brackets/{} \;
+ cp ${srcdir}/opt/brackets/Brackets ${pkgdir}/opt/brackets/
chmod 4755 ${pkgdir}/opt/brackets/chrome-sandbox
cd ${srcdir}/${pkgname}
cp -R "samples" "${pkgdir}/opt/brackets/samples"
cp -R "dist" "${pkgdir}/opt/brackets/www"
- #cp -R "node_modules" "${pkgdir}/opt/brackets/www"
+ cp -R "node_modules" "${pkgdir}/opt/brackets/www"
}