summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2019-05-14 17:38:59 +0100
committerAlex Dewar2019-05-14 17:38:59 +0100
commite0df1cfcfcd38f3a9d1dfde50eac27f86ac245e9 (patch)
treeaedb4142fa6cea4d1d1ef39e508cb235cb09f005
downloadaur-e0df1cfcfcd38f3a9d1dfde50eac27f86ac245e9.tar.gz
v0.7.3+
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD37
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88aa02344a7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brahms-git
+ pkgdesc = The BRAHMS simulation execution engine
+ pkgver = 0.7.3+git32ca5f7
+ pkgrel = 1
+ url = https://github.com/BRAHMS-SystemML/brahms
+ arch = i686
+ arch = x86_64
+ makedepends = git
+ makedepends = cmake
+ depends = zlib
+ provides = brahms
+ conflicts = brahms
+ source = git+https://github.com/BRAHMS-SystemML/brahms
+ md5sums = SKIP
+
+pkgname = brahms-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4731870b0905
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+/brahms
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..535dbeceebf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alex Dewar <a.dewar@sussex.ac.uk>
+pkgname=brahms-git
+pkgver=0.7.3+git32ca5f7
+pkgrel=1
+pkgdesc="The BRAHMS simulation execution engine"
+arch=(i686 x86_64)
+url="https://github.com/BRAHMS-SystemML/brahms"
+groups=()
+depends=(zlib)
+makedepends=(git cmake)
+provides=("brahms")
+conflicts=("brahms")
+source=("git+$url")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "brahms"
+ echo 0.7.3+git$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "brahms"
+ rm -rf build
+ mkdir build
+ cd build
+ cmake -DSTANDALONE_INSTALL=OFF -DCOMPILE_WITH_X11=OFF -DCMAKE_INSTALL_PREFIX=/usr ..
+}
+
+build() {
+ cd "brahms/build"
+ make
+}
+
+package() {
+ cd "brahms/build"
+ make DESTDIR="$pkgdir" install
+}