summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 15:31:25 +0200
committersmls2015-07-09 15:31:25 +0200
commit00d7651cc28ba4b1f2a816181bad035bad0fc5c0 (patch)
tree59a30253ce5e7312c49ad4a5b051ffd27c1dbe4c
downloadaur-00d7651cc28ba4b1f2a816181bad035bad0fc5c0.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
-rw-r--r--braid.desktop10
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b636bf70ac5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = braid-hib
+ pkgdesc = A puzzle-platformer where the player manipulates the flow of time (Humble Bundle/Store version)
+ pkgver = 1.0.2
+ pkgrel = 2
+ url = http://braid-game.com
+ arch = i686
+ arch = x86_64
+ license = custom: "commercial"
+ makedepends = unzip
+ depends = sdl
+ depends = nvidia-cg-toolkit
+ depends = libgl
+ optdepends = libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers
+ options = !strip
+ options = !upx
+ source = braid-linux-build2.run.bin::hib://braid-linux-build2.run.bin
+ source = braid.desktop
+ md5sums = f8933b7f7c77a234763cf73e2f9312a7
+ md5sums = e479ba41d20c1a15a9d8a29fd3b4ff76
+
+pkgname = braid-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27fc47694399
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+# Contributor: trya <tryagainprod@gmail.com>
+
+pkgname=braid-hib
+pkgver=1.0.2
+pkgrel=2
+pkgdesc="A puzzle-platformer where the player manipulates the flow of time (Humble Bundle/Store version)"
+url="http://braid-game.com"
+license=('custom: "commercial"')
+arch=('i686' 'x86_64')
+depends=('sdl' 'nvidia-cg-toolkit' 'libgl')
+optdepends=('libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers')
+makedepends=('unzip')
+options=('!strip' '!upx')
+PKGEXT='.pkg.tar'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+_gamepkg="braid-linux-build2.run.bin"
+source=("$_gamepkg::hib://$_gamepkg"
+ 'braid.desktop')
+md5sums=('f8933b7f7c77a234763cf73e2f9312a7'
+ 'e479ba41d20c1a15a9d8a29fd3b4ff76')
+
+build() {
+ cd "$srcdir"
+ unzip -o $_gamepkg || true
+
+ # Create launch script
+ echo -e '#!/bin/sh\ncd /opt/Braid && ./braid "$@"' > "$srcdir"/launcher
+}
+
+package() {
+ cd "$srcdir"
+ [ $CARCH == "i686" ] && _arch=x86 || _arch=amd64
+
+ # Install game files
+ install -d "$pkgdir"/opt/Braid
+ cp -a data/gamedata/{data,README-linux.txt} "$pkgdir"/opt/Braid/
+ install -Dm755 data/$_arch/braid "$pkgdir"/opt/Braid/braid
+
+ # Install launch script
+ install -Dm755 launcher "$pkgdir"/usr/bin/braid
+
+ # Install icon & desktop entry
+ install -Dm644 data/gamedata/braid.png "$pkgdir"/usr/share/pixmaps/braid.png
+ install -Dm644 braid.desktop "$pkgdir"/usr/share/applications/braid.desktop
+
+ # Install licenses
+ install -d "$pkgdir"/usr/share/licenses/braid
+ cp -a data/gamedata/licenses "$pkgdir"/usr/share/licenses/braid/
+}
diff --git a/braid.desktop b/braid.desktop
new file mode 100644
index 000000000000..b9a1c58b2c03
--- /dev/null
+++ b/braid.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Value=1.0
+Type=Application
+Categories=Game;
+Name=Braid
+Comment=Number None
+GenericName=Time-bending Puzzle Platformer
+Icon=braid
+Exec=braid
+Terminal=false