summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-28 19:04:24 +0200
committersmls2015-07-28 19:04:24 +0200
commit10609917435910340664590770c3e8bc569e9f3e (patch)
tree7bf37faaf63072913e6d01bdaf0674016c56b1e2
parent2c98704e4105f2ec804ed2d180a49d783bfdd99a (diff)
downloadaur-10609917435910340664590770c3e8bc569e9f3e.tar.gz
update to new HIB build
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD66
2 files changed, 48 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be8ac27e904e..6b31e628e5b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = braid-hib
pkgdesc = A puzzle platformer where you manipulate the flow of time (Humble Bundle/Store version)
- pkgver = 1.0.2+h20110807
+ pkgver = 1.1+h20150611
pkgrel = 1
url = http://braid-game.com
arch = i686
arch = x86_64
license = custom: "commercial"
- makedepends = unzip
- depends = sdl
- depends = nvidia-cg-toolkit
- depends = libgl
- optdepends = libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers
+ depends = xdg-utils
replaces = braid
options = !strip
options = !upx
- source = braid-linux-build2.run.bin::hib://braid-linux-build2.run.bin
+ source = BraidSetup-2015-06-11.sh::hib://BraidSetup-2015-06-11.sh
source = braid.desktop
- md5sums = f8933b7f7c77a234763cf73e2f9312a7
+ md5sums = 3650fa470b4794677086e792ddc29aa5
md5sums = e479ba41d20c1a15a9d8a29fd3b4ff76
+ depends_i686 = sdl2
+ depends_i686 = nvidia-cg-toolkit
+ depends_i686 = fltk
+ optdepends_i686 = libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers
+ depends_x86_64 = lib32-sdl2
+ depends_x86_64 = lib32-nvidia-cg-toolkit
+ depends_x86_64 = lib32-fltk
+ optdepends_x86_64 = lib32-libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers
pkgname = braid-hib
diff --git a/PKGBUILD b/PKGBUILD
index b617efe26032..39cdf013fa23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,51 +2,57 @@
# Contributor: trya <tryagainprod@gmail.com>
pkgname=braid-hib
-pkgver=1.0.2+h20110807
+pkgver=1.1+h20150611
+_hibver=2015-06-11
pkgrel=1
pkgdesc="A puzzle platformer where you manipulate the flow of time (Humble Bundle/Store version)"
url="http://braid-game.com"
license=('custom: "commercial"')
arch=('i686' 'x86_64')
-depends=('sdl' 'nvidia-cg-toolkit' 'libgl')
-optdepends=('libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers')
-makedepends=('unzip')
+depends=('xdg-utils')
+depends_i686=('sdl2' 'nvidia-cg-toolkit' 'fltk')
+depends_x86_64=('lib32-sdl2' 'lib32-nvidia-cg-toolkit' 'lib32-fltk')
+optdepends_i686=('libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers')
+optdepends_x86_64=('lib32-libtxc_dxtn: For more efficient texture handling when using one of the open-source Mesa graphics drivers')
options=('!strip' '!upx')
replaces=('braid')
PKGEXT='.pkg.tar'
DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
-_gamepkg="braid-linux-build2.run.bin"
+_gamepkg="BraidSetup-$_hibver.sh"
source=("$_gamepkg::hib://$_gamepkg"
'braid.desktop')
-md5sums=('f8933b7f7c77a234763cf73e2f9312a7'
+md5sums=('3650fa470b4794677086e792ddc29aa5'
'e479ba41d20c1a15a9d8a29fd3b4ff76')
-build() {
- cd "$srcdir"
- unzip -o $_gamepkg || true
-
- # Create launch script
- echo -e '#!/bin/sh\ncd /opt/Braid && ./braid "$@"' > "$srcdir"/launcher
+_target=/opt/braid
+
+prepare() {
+ # Create launch script
+ echo -e '#!/usr/bin/sh\n'\
+ "cd $_target\n"\
+ 'exec ./Braid.bin.x86 "$@"'\
+ > "$srcdir"/launcher.sh
}
package() {
- cd "$srcdir"
- [ $CARCH == "i686" ] && _arch=x86 || _arch=amd64
-
- # Install game files
- install -d "$pkgdir"/opt/Braid
- cp -a data/gamedata/{data,README-linux.txt} "$pkgdir"/opt/Braid/
- install -Dm755 data/$_arch/braid "$pkgdir"/opt/Braid/braid
-
- # Install launch script
- install -Dm755 launcher "$pkgdir"/usr/bin/braid
-
- # Install icon & desktop entry
- install -Dm644 data/gamedata/braid.png "$pkgdir"/usr/share/pixmaps/braid.png
- install -Dm644 braid.desktop "$pkgdir"/usr/share/applications/braid.desktop
-
- # Install licenses
- install -d "$pkgdir"/usr/share/licenses/braid
- cp -a data/gamedata/licenses "$pkgdir"/usr/share/licenses/braid/
+ # Install game files
+ install -d "$pkgdir"/$_target
+ cp -a data/noarch/data "$pkgdir"/$_target
+ cp -a data/x86/{Braid.bin.x86,launcher.bin.x86} "$pkgdir"/$_target
+
+ # Install docs
+ install -d "$pkgdir"/usr/share/doc/braid
+ cp -a data/noarch/{README.linux,READ_ME.txt} "$pkgdir"/usr/share/doc/braid
+
+ # Install launch script
+ install -Dm755 launcher.sh "$pkgdir"/usr/bin/braid
+
+ # Install icon & desktop entry
+ install -Dm644 data/noarch/Icon.png "$pkgdir"/usr/share/pixmaps/braid.png
+ install -Dm644 braid.desktop "$pkgdir"/usr/share/applications/braid.desktop
+
+ # Install licenses
+ install -d "$pkgdir"/usr/share/licenses/braid
+ cp -a data/noarch/licenses/* "$pkgdir"/usr/share/licenses/braid/
}