summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFigue2020-10-16 14:23:46 +0200
committerFigue2020-10-16 14:23:46 +0200
commit2149134285d6aa14a5e00bcefef49e580c4af25e (patch)
treec337e91c4492096799fed02091b87b295bd9d1bb
parenteae19abe6382c0f0c4111b12946a89f25002d9fe (diff)
downloadaur-2149134285d6aa14a5e00bcefef49e580c4af25e.tar.gz
1.15.75
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD4
-rw-r--r--brave-custom-build.patch26
3 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5edd74c4d92..a0a5ae5bf3b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = brave
pkgdesc = A web browser that stops ads and trackers by default
- pkgver = 1.15.72
+ pkgver = 1.15.75
pkgrel = 1
url = https://www.brave.com/download
arch = x86_64
@@ -14,10 +14,6 @@ pkgbase = brave
makedepends = java-runtime-headless
makedepends = clang
makedepends = python2-setuptools
- makedepends = lld
- makedepends = libva
- makedepends = libpipewire02
- makedepends = python2-xcb-proto
depends = gtk3
depends = nss
depends = alsa-lib
@@ -39,15 +35,13 @@ pkgbase = brave
depends = libxslt
depends = freetype2
depends = opus
- depends = libpulse
- depends = pciutils
optdepends = cups: Printer support
optdepends = pepper-flash: Adobe Flash support
optdepends = libpipewire02: WebRTC desktop sharing under Wayland
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
optdepends = kwallet: for storing passwords in KWallet on KDE desktops
optdepends = sccache: For faster builds
- source = git+https://github.com/brave/brave-browser.git#tag=v1.15.72
+ source = git+https://github.com/brave/brave-browser.git#tag=v1.15.75
source = brave-launcher
source = brave-browser.desktop
source = https://github.com/stha09/chromium-patches/releases/download/chromium-86-patchset-6/chromium-86-patchset-6.tar.xz
@@ -61,7 +55,7 @@ pkgbase = brave
sha256sums = 725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5
sha256sums = fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d
sha256sums = 6f9ab35fa2c9e6e34ec454b829b7b87adaebc10cacecd1ac1daa67035ee44aba
- sha256sums = c5ebde144e4f31ce5e6a37aa6a6233489b6b40b03464b9d6077c777f5ad14ac1
+ sha256sums = 0a129f1346a68a2e2c04be4503747151988e624fad6231b12b36475047da6579
sha256sums = 69d8b7a439db1af4713245ddf5f44ca647283ba833a8733e848033ebdaf03cdc
sha256sums = 7514c6c81a64a5457b66494a366fbb39005563eecc48d1a39033dd06aec4e300
sha256sums = 7cace84d7494190e7882d3e637820646ec8d64808f0a2128c515bd44991a3790
diff --git a/PKGBUILD b/PKGBUILD
index 1056c8aa8dfb..95c7ba4f8a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ fi
_reponame=brave-browser
pkgname=brave
-pkgver=1.15.72
+pkgver=1.15.75
pkgrel=1
pkgdesc='A web browser that stops ads and trackers by default'
arch=('x86_64')
@@ -68,7 +68,7 @@ sha256sums=('SKIP'
'725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5'
'fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d'
'6f9ab35fa2c9e6e34ec454b829b7b87adaebc10cacecd1ac1daa67035ee44aba'
- 'c5ebde144e4f31ce5e6a37aa6a6233489b6b40b03464b9d6077c777f5ad14ac1'
+ '0a129f1346a68a2e2c04be4503747151988e624fad6231b12b36475047da6579'
'69d8b7a439db1af4713245ddf5f44ca647283ba833a8733e848033ebdaf03cdc'
'7514c6c81a64a5457b66494a366fbb39005563eecc48d1a39033dd06aec4e300'
'7cace84d7494190e7882d3e637820646ec8d64808f0a2128c515bd44991a3790'
diff --git a/brave-custom-build.patch b/brave-custom-build.patch
index ef56a690433c..dbcf8a301b4e 100644
--- a/brave-custom-build.patch
+++ b/brave-custom-build.patch
@@ -133,10 +133,22 @@ index 67bd13c94d..5e8e8736f5 100644
--- a/brave/vendor/bat-native-ads/src/bat/ads/internal/filters/ads_history_conversion_filter.cc
+++ b/brave/vendor/bat-native-ads/src/bat/ads/internal/filters/ads_history_conversion_filter.cc
@@ -4,6 +4,7 @@
- * You can obtain one at http://mozilla.org/MPL/2.0/. */
-
- #include "bat/ads/internal/filters/ads_history_conversion_filter.h"
-+#include <algorithm>
-
- namespace ads {
-
+ * You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+ #include "bat/ads/internal/filters/ads_history_conversion_filter.h"
++#include <algorithm>
+
+ namespace ads {
+
+diff --git a/brave/components/ipfs/common/ipfs_utils.cc b/brave/components/ipfs/common/ipfs_utils.cc
+index de984233dc..9414da92a3 100644
+--- a/brave/components/ipfs/common/ipfs_utils.cc
++++ b/brave/components/ipfs/common/ipfs_utils.cc
+@@ -6,6 +6,7 @@
+ #include "brave/components/ipfs/common/ipfs_utils.h"
+
+ #include <vector>
++#include <algorithm>
+
+ #include "url/gurl.h"
+ #include "extensions/common/url_pattern.h"