summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2020-09-20 18:36:49 +0200
committerJoan Figueras2020-09-20 18:37:42 +0200
commit6e6c27db0f74ef9a2f8b731eb03340d30c470048 (patch)
treeab8da956485ca2ae6d67d64ca3e87ba855070760
parentecf0af9df299b7f17e660b3969abc0b64705d672 (diff)
downloadaur-6e6c27db0f74ef9a2f8b731eb03340d30c470048.tar.gz
Removed chromium-no-history patch for now
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--chromium-no-history.patch12
3 files changed, 0 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2178f7f4f06c..1ee6bd8e4345 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -42,7 +42,6 @@ pkgbase = brave
optdepends = kwallet: for storing passwords in KWallet on KDE desktops
optdepends = sccache: For faster builds
source = git+https://github.com/brave/brave-browser.git#tag=v1.14.81
- source = chromium-no-history.patch
source = brave-launcher
source = brave-browser.desktop
source = https://github.com/stha09/chromium-patches/releases/download/chromium-85-patchset-2/chromium-85-patchset-2.tar.xz
@@ -50,7 +49,6 @@ pkgbase = brave
source = media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch?h=packages/chromium&id=51efcaea600acd0648cb70730911f64f332feb95
source = chromium-skia-harmony.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-skia-harmony.patch?h=packages/chromium&id=51efcaea600acd0648cb70730911f64f332feb95
sha256sums = SKIP
- sha256sums = e7dd5f8bc6959d2d0c14c7f70687303d3152eae9a50628fbb025b834d62a52d7
sha256sums = 725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5
sha256sums = fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d
sha256sums = 2194fe22b9e5ccdc4a86da4e3572214f670c561486671f57c90636fd3cbfa43e
diff --git a/PKGBUILD b/PKGBUILD
index b179d056facc..e87f4f31300d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,7 +46,6 @@ chromium_base_ver="85"
patchset="2"
patchset_name="chromium-${chromium_base_ver}-patchset-${patchset}"
source=("git+https://github.com/brave/brave-browser.git#tag=v${pkgver}"
- 'chromium-no-history.patch'
'brave-launcher'
'brave-browser.desktop'
"https://github.com/stha09/chromium-patches/releases/download/${patchset_name}/${patchset_name}.tar.xz")
@@ -63,7 +62,6 @@ done
#source+=("vdpau-support.patch::https://aur.archlinux.org/cgit/aur.git/plain/vdpau-support.patch?h=chromium-vaapi&id=7c05464a8700b1a6144258320b2b33b352385f77")
sha256sums=('SKIP'
- 'e7dd5f8bc6959d2d0c14c7f70687303d3152eae9a50628fbb025b834d62a52d7'
'725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5'
'fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d'
'2194fe22b9e5ccdc4a86da4e3572214f670c561486671f57c90636fd3cbfa43e'
@@ -107,9 +105,6 @@ fi
prepare() {
cd "${_reponame}"
- # Patch to download only sources, but not all history
- #patch -Np1 -i "${srcdir}"/chromium-no-history.patch
-
# Hack to prioritize python2 in PATH
mkdir -p "${srcdir}/bin"
ln -sf /usr/bin/python2 "${srcdir}/bin/python"
diff --git a/chromium-no-history.patch b/chromium-no-history.patch
deleted file mode 100644
index edfec7bc986f..000000000000
--- a/chromium-no-history.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/lib/util.js 2020-07-17 22:23:08.832588013 +0200
-+++ b/lib/util.js 2020-07-17 22:26:52.894403279 +0200
-@@ -614,7 +614,7 @@
- let reset = forceReset
-
- // base args
-- const initialArgs = ['sync', '--reset', '--nohooks']
-+ const initialArgs = ['sync', '--no-history', '--shallow', '--reset', '--nohooks']
- const chromiumArgs = ['--revision', 'src@' + config.getProjectRef('chrome')]
- const resetArgs = ['--with_tags', '--with_branch_heads', '--upstream']
-
-