summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2020-10-03 09:13:35 +0200
committerJoan Figueras2020-10-03 09:13:35 +0200
commitb5418543b8d35e01f8919a38c6b3d5e45d52b218 (patch)
tree013bec12b00f4ac6e7ad64cebc9082b37c3ddfe3
parent21817a97d970beaf81d8ff8062505085e2c18632 (diff)
downloadaur-b5418543b8d35e01f8919a38c6b3d5e45d52b218.tar.gz
Enabled custom build patch. Thanks Jacek
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--brave-custom-build.patch143
3 files changed, 79 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fb1980d2ee6..c653e4f4ac5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brave
pkgdesc = A web browser that stops ads and trackers by default
pkgver = 1.14.84
- pkgrel = 1
+ pkgrel = 2
url = https://www.brave.com/download
arch = x86_64
license = custom
@@ -45,6 +45,7 @@ pkgbase = brave
source = brave-launcher
source = brave-browser.desktop
source = https://github.com/stha09/chromium-patches/releases/download/chromium-85-patchset-2/chromium-85-patchset-2.tar.xz
+ source = brave-custom-build.patch
source = chromium-fix-vaapi-on-intel.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-fix-vaapi-on-intel.patch?h=packages/chromium&id=51efcaea600acd0648cb70730911f64f332feb95
source = media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch?h=packages/chromium&id=51efcaea600acd0648cb70730911f64f332feb95
source = chromium-skia-harmony.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-skia-harmony.patch?h=packages/chromium&id=51efcaea600acd0648cb70730911f64f332feb95
@@ -52,6 +53,7 @@ pkgbase = brave
sha256sums = 725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5
sha256sums = fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d
sha256sums = 2194fe22b9e5ccdc4a86da4e3572214f670c561486671f57c90636fd3cbfa43e
+ sha256sums = c5ebde144e4f31ce5e6a37aa6a6233489b6b40b03464b9d6077c777f5ad14ac1
sha256sums = e495f2477091557b15bff2c99831e0a3db64ea2ebde7dcb22857a6469c944b9a
sha256sums = 0f041d655335cd2a4773ae7ca5e301a0ff12c6c53f57b7cf6651c268e0420a1c
sha256sums = 771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1
diff --git a/PKGBUILD b/PKGBUILD
index 9fb0bdc86d32..9cbe7535cabb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ fi
_reponame=brave-browser
pkgname=brave
pkgver=1.14.84
-pkgrel=1
+pkgrel=2
pkgdesc='A web browser that stops ads and trackers by default'
arch=('x86_64')
url='https://www.brave.com/download'
@@ -48,7 +48,8 @@ patchset_name="chromium-${chromium_base_ver}-patchset-${patchset}"
source=("git+https://github.com/brave/brave-browser.git#tag=v${pkgver}"
'brave-launcher'
'brave-browser.desktop'
- "https://github.com/stha09/chromium-patches/releases/download/${patchset_name}/${patchset_name}.tar.xz")
+ "https://github.com/stha09/chromium-patches/releases/download/${patchset_name}/${patchset_name}.tar.xz"
+ 'brave-custom-build.patch')
arch_revision=51efcaea600acd0648cb70730911f64f332feb95
for Patches in \
chromium-fix-vaapi-on-intel.patch \
@@ -65,6 +66,7 @@ sha256sums=('SKIP'
'725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5'
'fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d'
'2194fe22b9e5ccdc4a86da4e3572214f670c561486671f57c90636fd3cbfa43e'
+ 'c5ebde144e4f31ce5e6a37aa6a6233489b6b40b03464b9d6077c777f5ad14ac1'
'e495f2477091557b15bff2c99831e0a3db64ea2ebde7dcb22857a6469c944b9a'
'0f041d655335cd2a4773ae7ca5e301a0ff12c6c53f57b7cf6651c268e0420a1c'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
@@ -147,7 +149,7 @@ prepare() {
msg2 "Add patches for custom build"
local _patch
- for _patch in "$srcdir/patches"/*.patch; do
+ for _patch in "$srcdir/brave-custom-build.patch" "$srcdir/patches"/*.patch; do
patch -Np1 -i "$_patch"
done
diff --git a/brave-custom-build.patch b/brave-custom-build.patch
index f2510937a15e..ef56a690433c 100644
--- a/brave-custom-build.patch
+++ b/brave-custom-build.patch
@@ -1,8 +1,7 @@
-diff --git a/brave/BUILD.gn b/brave/BUILD.gn
-index c3907daf6..ef9cd2f6c 100644
---- a/brave/BUILD.gn
-+++ b/brave/BUILD.gn
-@@ -4,6 +4,7 @@ import("//brave/build/config.gni")
+diff -ru a/brave/BUILD.gn b/brave/BUILD.gn
+--- a/brave/BUILD.gn 2020-09-25 22:55:12.193333434 +0200
++++ b/brave/BUILD.gn 2020-10-01 12:15:47.486663146 +0200
+@@ -4,6 +4,7 @@
import("//ui/base/ui_features.gni")
import("//third_party/icu/config.gni")
import("//build/config/locales.gni")
@@ -10,7 +9,7 @@ index c3907daf6..ef9cd2f6c 100644
import("//build/util/process_version.gni")
import("//extensions/buildflags/buildflags.gni")
import("//media/cdm/library_cdm/cdm_paths.gni")
-@@ -205,8 +205,11 @@ group("create_dist") {
+@@ -238,8 +239,11 @@
}
}
if (is_linux) {
@@ -23,7 +22,7 @@ index c3907daf6..ef9cd2f6c 100644
"//brave/app/linux:dist_resources",
":theme_files",
]
-@@ -328,9 +331,12 @@ if (!is_android && !is_ios) {
+@@ -336,9 +340,12 @@
":packed_resources",
"build/$target_os:brave",
"//chrome:packed_resources",
@@ -37,7 +36,7 @@ index c3907daf6..ef9cd2f6c 100644
if (!is_mac) {
sources += [
"$root_out_dir/brave_resources.pak",
-@@ -339,10 +345,13 @@ if (!is_android && !is_ios) {
+@@ -347,10 +354,13 @@
"$root_out_dir/$brave_exe",
"$root_out_dir/chrome_100_percent.pak",
"$root_out_dir/chrome_200_percent.pak",
@@ -52,20 +51,42 @@ index c3907daf6..ef9cd2f6c 100644
if (v8_use_external_startup_data) {
deps += [ "//v8" ]
-diff --git a/brave/vendor/adblock_rust_ffi/src/wrapper.cpp b/brave/vendor/adblock_rust_ffi/src/wrapper.cpp
-index f13a777..2b4e90a 100644
---- a/brave/vendor/adblock_rust_ffi/src/wrapper.cpp
-+++ b/brave/vendor/adblock_rust_ffi/src/wrapper.cpp
+diff -ru a/brave/components/brave_rewards/browser/logging.h b/brave/components/brave_rewards/browser/logging.h
+--- a/brave/components/brave_rewards/browser/logging.h 2020-09-25 22:55:11.176666768 +0200
++++ b/brave/components/brave_rewards/browser/logging.h 2020-10-01 12:16:30.493329812 +0200
+@@ -11,7 +11,7 @@
+ namespace brave_rewards {
+
+ #define BLOG(verbose_level, stream) Log(__FILE__, __LINE__, \
+- verbose_level, (std::ostringstream() << stream).str());
++ verbose_level, static_cast<std::ostringstream &>(std::ostringstream() << stream).str());
+
+ #define BLOG_IF(verbose_level, condition, stream) \
+ !(condition) ? (void) 0 : BLOG(verbose_level, stream)
+diff -ru a/brave/vendor/adblock_rust_ffi/src/wrapper.cpp b/brave/vendor/adblock_rust_ffi/src/wrapper.cpp
+--- a/brave/vendor/adblock_rust_ffi/src/wrapper.cpp 2020-09-26 00:29:10.890000602 +0200
++++ b/brave/vendor/adblock_rust_ffi/src/wrapper.cpp 2020-10-01 12:15:47.649996482 +0200
@@ -1,4 +1,5 @@
#include "wrapper.hpp"
+#include <cstring>
#include <iostream>
using namespace std;
-diff --git a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc
-index eeaec36bc..c919332b0 100644
---- a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc
-+++ b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc
+diff -ru a/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h b/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h
+--- a/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h 2020-09-25 22:55:11.660000101 +0200
++++ b/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h 2020-10-01 12:15:47.669996481 +0200
+@@ -52,7 +52,7 @@
+ // 8 Database queries
+
+ #define BLOG(verbose_level, stream) ads::Log(__FILE__, __LINE__, \
+- verbose_level, (std::ostringstream() << stream).str());
++ verbose_level, static_cast<std::ostringstream &>(std::ostringstream() << stream).str());
+
+ // You can also do conditional verbose logging when some extra computation and
+ // preparation for logs is not needed:
+diff -ru a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc
+--- a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc 2020-09-25 22:55:12.273333434 +0200
++++ b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/contribution/contribution.cc 2020-10-01 12:15:47.663329814 +0200
@@ -7,6 +7,7 @@
#include <algorithm>
@@ -74,10 +95,21 @@ index eeaec36bc..c919332b0 100644
#include <memory>
#include <utility>
#include <vector>
-diff --git a/brave/vendor/bat-native-usermodel/src/transformation.cc b/brave/vendor/bat-native-usermodel/src/transformation.cc
-index f6e0a17..86d2a10 100644
---- a/brave/vendor/bat-native-usermodel/src/transformation.cc
-+++ b/brave/vendor/bat-native-usermodel/src/transformation.cc
+diff -ru a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging/logging.h b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging/logging.h
+--- a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging/logging.h 2020-09-25 22:55:11.680000101 +0200
++++ b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging/logging.h 2020-10-01 12:38:06.619996468 +0200
+@@ -53,7 +53,7 @@
+ // 9 Detailed debugging (response headers, etc)
+
+ #define BLOG(verbose_level, stream) ledger::Log(__FILE__, __LINE__, \
+- verbose_level, (std::ostringstream() << stream).str());
++ verbose_level, static_cast<std::ostringstream &>(std::ostringstream() << stream).str());
+
+ // You can also do conditional verbose logging when some extra computation and
+ // preparation for logs is not needed:
+diff -ru a/brave/vendor/bat-native-usermodel/src/transformation.cc b/brave/vendor/bat-native-usermodel/src/transformation.cc
+--- a/brave/vendor/bat-native-usermodel/src/transformation.cc 2020-09-26 00:30:07.446667262 +0200
++++ b/brave/vendor/bat-native-usermodel/src/transformation.cc 2020-10-01 12:15:47.669996481 +0200
@@ -4,6 +4,7 @@
* You can obtain one at http://mozilla.org/MPL/2.0/. */
@@ -86,58 +118,25 @@ index f6e0a17..86d2a10 100644
#include <codecvt>
#include <math.h>
namespace usermodel {
-diff --git a/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h b/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h
-index 4f927a7d1..6367a43cc 100644
---- a/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h
-+++ b/brave/vendor/bat-native-ads/src/bat/ads/internal/logging.h
-@@ -52,7 +52,7 @@ void Log(
- // 8 Database queries
-
- #define BLOG(verbose_level, stream) ads::Log(__FILE__, __LINE__, \
-- verbose_level, (std::ostringstream() << stream).str());
-+ verbose_level, static_cast<std::ostringstream &>(std::ostringstream() << stream).str());
-
- // You can also do conditional verbose logging when some extra computation and
- // preparation for logs is not needed:
-
-diff --git a/brave/vendor/bat-native-confirmations/src/bat/confirmations/internal/logging.h b/brave/vendor/bat-native-confirmations/src/bat/confirmations/internal/logging.h
-index 73f259f0c..8ed1f196f 100644
---- a/brave/vendor/bat-native-confirmations/src/bat/confirmations/internal/logging.h
-+++ b/brave/vendor/bat-native-confirmations/src/bat/confirmations/internal/logging.h
-@@ -51,7 +51,7 @@ void Log(
- // 8 Database queries
+--- a/brave/vendor/bat-native-ads/src/bat/ads/internal/classification/classification_util.cc 2020-10-01 16:12:59.776666163 +0200
++++ b/brave/vendor/bat-native-ads/src/bat/ads/internal/classification/classification_util.cc 2020-10-01 17:26:05.076665847 +0200
+@@ -5,6 +5,7 @@
- #define BLOG(verbose_level, stream) confirmations::Log(__FILE__, \
-- __LINE__, verbose_level, (std::ostringstream() << stream).str());
-+ __LINE__, verbose_level, static_cast<std::ostringstream &>(std::ostringstream() << stream).str());
+ #include "bat/ads/internal/classification/classification_util.h"
- // You can also do conditional verbose logging when some extra computation and
- // preparation for logs is not needed:
-diff --git a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging.h b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging.h
-index fa62ecbef..347819840 100644
---- a/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging.h
-+++ b/brave/vendor/bat-native-ledger/src/bat/ledger/internal/logging.h
-@@ -52,7 +52,7 @@ void Log(
- // 8 Database queries
-
- #define BLOG(verbose_level, stream) ledger::Log(__FILE__, __LINE__, \
-- verbose_level, (std::ostringstream() << stream).str());
-+ verbose_level, static_cast<std::ostringstream &>(std::ostringstream() << stream).str());
-
- // You can also do conditional verbose logging when some extra computation and
- // preparation for logs is not needed:
-
-diff --git a/brave/components/brave_rewards/browser/logging.h b/brave/components/brave_rewards/browser/logging.h
-index c3171e9b2..b96c5b447 100644
---- a/brave/components/brave_rewards/browser/logging.h
-+++ b/brave/components/brave_rewards/browser/logging.h
-@@ -11,7 +11,7 @@
- namespace brave_rewards {
-
- #define BLOG(verbose_level, stream) Log(__FILE__, __LINE__, \
-- verbose_level, (std::ostringstream() << stream).str());
-+ verbose_level, static_cast<std::ostringstream &>(std::ostringstream() << stream).str());
++#include <algorithm>
+ #include "base/strings/string_split.h"
- #define BLOG_IF(verbose_level, condition, stream) \
- !(condition) ? (void) 0 : BLOG(verbose_level, stream)
-
+ namespace ads {
+diff --git a/brave/vendor/bat-native-ads/src/bat/ads/internal/filters/ads_history_conversion_filter.cc b/brave/vendor/bat-native-ads/src/bat/ads/internal/filters/ads_history_conversion_filter.cc
+index 67bd13c94d..5e8e8736f5 100644
+--- a/brave/vendor/bat-native-ads/src/bat/ads/internal/filters/ads_history_conversion_filter.cc
++++ b/brave/vendor/bat-native-ads/src/bat/ads/internal/filters/ads_history_conversion_filter.cc
+@@ -4,6 +4,7 @@
+ * You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+ #include "bat/ads/internal/filters/ads_history_conversion_filter.h"
++#include <algorithm>
+
+ namespace ads {
+