summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.A. López-Valencia2016-10-21 08:24:43 -0500
committerP.A. López-Valencia2016-10-21 08:24:43 -0500
commit2b63dbdad4ad6d9ec6302322a5e898cc3df356b2 (patch)
treed2a032e15474396c76adf4b9caed1b3423205a26
parent955e5c7dcafd9b16414aa1c3dde06ae94348eddf (diff)
downloadaur-2b63dbdad4ad6d9ec6302322a5e898cc3df356b2.tar.gz
Follow dev-channel as master branch is a bit stale.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a69b6517c65..9f47bd3e76c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = brave-git
pkgdesc = A web browser that stops ads and trackers by default. Master branch.
- pkgver = 0.12.4.4
+ pkgver = 0.12.6.Preview2
pkgrel = 1
url = https://www.brave.com/
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = brave-git
provides = brave
provides = brave-browser
conflicts = brave
- source = git://github.com/brave/browser-laptop.git
+ source = git://github.com/brave/browser-laptop.git#branch=dev-channel
source = brave.desktop
sha384sums = SKIP
sha384sums = f950675fb4a3f9e48374f8a2667e7a45889206a3062c8182e474143607fc26bd17e852a1ef494607dbd3ff4de325e05f
diff --git a/PKGBUILD b/PKGBUILD
index ac027fb6aa2a..ba3eed503cbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=brave-git
_pkgname=browser-laptop
-pkgver=0.12.4.4
+pkgver=0.12.6.Preview2
pkgrel=1
pkgdesc="A web browser that stops ads and trackers by default. Master branch."
arch=('x86_64') # Upstream supports x86_64 only
@@ -14,7 +14,7 @@ makedepends=('git' 'npm')
optdepends=('cups: To print stuff')
provides=('brave' 'brave-browser')
conflicts=('brave')
-source=("git://github.com/brave/browser-laptop.git"
+source=("git://github.com/brave/browser-laptop.git#branch=dev-channel"
'brave.desktop')
sha384sums=('SKIP'
'f950675fb4a3f9e48374f8a2667e7a45889206a3062c8182e474143607fc26bd17e852a1ef494607dbd3ff4de325e05f')
@@ -22,10 +22,12 @@ sha384sums=('SKIP'
pkgver() {
cd "$srcdir/$_pkgname"
- # Please note that this version hack works here because this package will track master *always*
- # and upstream has a defined tagging and versioning policy.
+ # Please note that this version hack works here because this package
+ # intends to track dev-channel, you can track master instead, just edit
+ # above to your heart's content.
+ # Upstream has a defined tagging and versioning policy, often.
printf %s \
- $(git describe --tags | sed -e 's/^v//' -e 's/dev//' -e 's/-/./' -e 's/-.\+//') # It's fragile, needs work.
+ $(git describe --tags | sed -e 's/^v//' -e 's/dev//' -e 's/-/./' -e 's/-.\+//') # Version extraction is fragile and needs work.
}
build() {