summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatataofcourse2023-09-26 12:08:36 +0200
committerpatataofcourse2023-09-26 12:08:36 +0200
commit42e037128f2cdb5b29d9ba55a479448a77ecf746 (patch)
tree2eb8908fdb2a0d1346e8b9fae83e4766b71ec42d
downloadaur-42e037128f2cdb5b29d9ba55a479448a77ecf746.tar.gz
initial commit tm
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
-rw-r--r--bread.desktop9
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57fa7d4df37e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bread-bin
+ pkgdesc = An editor for the BRCAD and BCCAD formats
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = https://github.com/rhmodding/Bread
+ arch = any
+ license = apache
+ depends = java-runtime=8
+ depends = bash
+ depends = java-openjfx=8
+ provides = bread
+ noextract = bread.jar
+ source = https://github.com/rhmodding/Bread/releases/download/v1.4.2/bread.jar
+ source = https://gist.githubusercontent.com/patataofcourse/a0b9732e2bb51a1c64c78e134a56745f/raw/55c3690171952c750bca50b3024380ba95991b87/bread.sh
+ source = https://raw.githubusercontent.com/rhmodding/bread/v1.4.2/icon.png
+ source = bread.desktop
+ sha256sums = 2369d44dd0e4c6a87c462ecab9e2e006eaa52397151e4301307d0d71b833348e
+ sha256sums = b8afb7aafe340ad57eef34c252421de09eefe37536b03eeb26194f79738f6a86
+ sha256sums = SKIP
+ sha256sums = d7a6bebe9addab87eedd34499e03b57397d06e835357c86b2c063343cd3834a6
+
+pkgname = bread-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e67b23a6c4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!bread.desktop \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0878d6ee1a7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: patataofcourse <patataofcourse@gmail.com>
+pkgname="bread-bin"
+pkgver="1.4.2"
+pkgrel=1
+pkgdesc="An editor for the BRCAD and BCCAD formats"
+arch=("any")
+url="https://github.com/rhmodding/Bread"
+license=('apache')
+depends=("java-runtime=8" "bash" "java-openjfx=8")
+provides=("bread")
+conflicts=()
+noextract=(
+ "bread.jar"
+)
+source=(
+ "https://github.com/rhmodding/Bread/releases/download/v$pkgver/bread.jar"
+ "https://gist.githubusercontent.com/patataofcourse/a0b9732e2bb51a1c64c78e134a56745f/raw/55c3690171952c750bca50b3024380ba95991b87/bread.sh"
+ "https://raw.githubusercontent.com/rhmodding/bread/v$pkgver/icon.png"
+ "bread.desktop"
+)
+sha256sums=(
+ "2369d44dd0e4c6a87c462ecab9e2e006eaa52397151e4301307d0d71b833348e"
+ "b8afb7aafe340ad57eef34c252421de09eefe37536b03eeb26194f79738f6a86"
+ SKIP
+ "d7a6bebe9addab87eedd34499e03b57397d06e835357c86b2c063343cd3834a6"
+)
+
+package() {
+ #cd "$pkgname-$pkgver"
+ install -Dm644 icon.png "$pkgdir/usr/share/pixmaps/bread.png"
+ install -Dm644 bread.desktop "$pkgdir/usr/share/applications/bread.desktop"
+ install -Dm644 bread.jar "$pkgdir/usr/share/java/bread/bread.jar"
+ install -D bread.sh "$pkgdir/usr/bin/bread"
+}
diff --git a/bread.desktop b/bread.desktop
new file mode 100644
index 000000000000..0385aeaa7d15
--- /dev/null
+++ b/bread.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.4.2
+Name=Bread
+Comment=An editor for the BRCAD and BCCAD formats
+Exec=bread
+Terminal=false
+Icon=bread
+Categories=Development;Graphics; \ No newline at end of file