summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-06-12 18:59:27 +0200
committerbartus2020-06-12 18:59:27 +0200
commit91e24a44c2bf76a553b2c19ea0ee44c5a7280a72 (patch)
tree55b46fbd8a86b5c5a1459177279f2694ca15ddd4
parent4101a2fc426ba4fc6577c7416c8dfed43a6c3047 (diff)
downloadaur-91e24a44c2bf76a553b2c19ea0ee44c5a7280a72.tar.gz
Refactor:
* rename to breakpad. * make symlink relative * change maintainer tag
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20b473c79ad0..2a4ea7b1b3f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = google-breakpad-git
+pkgbase = breakpad
pkgdesc = An open-source multi-platform crash reporting system
- pkgver = r1844.2ffe1163
+ pkgver = r1846.2757a2c9
pkgrel = 1
url = https://chromium.googlesource.com/breakpad/breakpad/
arch = i686
@@ -9,13 +9,14 @@ pkgbase = google-breakpad-git
license = BSD
makedepends = git
depends = gcc-libs
- conflicts = google-breakpad-svn
+ provides = google-breakpad
+ conflicts = google-breakpad-git
options = staticlibs
options = !strip
source = git+https://chromium.googlesource.com/breakpad/breakpad
source = git+https://chromium.googlesource.com/linux-syscall-support
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
-pkgname = google-breakpad-git
+pkgname = breakpad
diff --git a/PKGBUILD b/PKGBUILD
index a95a3cde1069..63b0df8d0a08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: Lars Hagström <lars@foldspace.nu>
-# Contributor: Nephyrin Zey <nephyrin@doublezen.net>
-# Contributor: John Schoenick <john@pointysoftware.net>
-# Contributor: Geoffrey Teale <tealeg@googlemail.com>
-_pkgname=breakpad
-pkgname=google-${_pkgname}-git
-pkgver=r1844.2ffe1163
+#!/hint/bash
+# Maintainer : bartus <arch-user-repository{at}bartus.33mail.com>
+# Contributor : Lars Hagström <lars@foldspace.nu>
+# Contributor : Nephyrin Zey <nephyrin@doublezen.net>
+# Contributor : John Schoenick <john@pointysoftware.net>
+# Contributor : Geoffrey Teale <tealeg@googlemail.com>
+
+pkgname=breakpad
+pkgver=r1846.2757a2c9
pkgrel=1
pkgdesc="An open-source multi-platform crash reporting system"
arch=('i686' 'x86_64' 'armv7h')
@@ -13,23 +15,24 @@ license=('BSD')
makedepends=('git')
depends=('gcc-libs')
options=('staticlibs' '!strip')
-conflicts=('google-breakpad-svn')
+conflicts=('google-breakpad-git')
+provides=('google-breakpad')
source=('git+https://chromium.googlesource.com/breakpad/breakpad'
'git+https://chromium.googlesource.com/linux-syscall-support')
-md5sums=('SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP')
prepare() {
- cd "$srcdir/${_pkgname}"
- ln -sT "${srcdir}/linux-syscall-support" "src/third_party/lss" || true # Don't fail if it exists
+ ln -sT "linux-syscall-support" "$pkgname/src/third_party/lss" || true # Don't fail if it exists
}
pkgver() {
- cd "$srcdir/${_pkgname}"
+ cd "$srcdir/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${_pkgname}"
+ cd "$srcdir/${pkgname}"
echo "Configuring"
autoreconf
@@ -39,7 +42,7 @@ build() {
}
package() {
- cd "$srcdir/${_pkgname}"
+ cd "$srcdir/${pkgname}"
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}