summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2019-03-13 08:55:39 -0400
committerJameson Pugh2019-03-13 08:55:39 -0400
commitbe0348a5f1e5e0563ff24608b03bde76351f4261 (patch)
tree2102472ac2617378b929cd8122effc8225a5c824
parent45034df3000d52f37f4c00e6c9485086665f5365 (diff)
downloadaur-be0348a5f1e5e0563ff24608b03bde76351f4261.tar.gz
5.15.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD13
-rw-r--r--breeze-plymouth.cpiohook49
3 files changed, 68 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 043ee72c0e12..46237b25d595 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
-# Generated by mksrcinfo v8
-# Tue Feb 26 18:56:33 UTC 2019
pkgbase = breeze-plymouth
pkgdesc = Breeze theme for plymouth
- pkgver = 5.15.2
+ pkgver = 5.15.3
pkgrel = 1
url = https://projects.kde.org/breeze-plymouth
arch = any
license = LGPL
makedepends = extra-cmake-modules
depends = plymouth
- source = http://download.kde.org/stable/plasma/5.15.2/breeze-plymouth-5.15.2.tar.xz
- source = http://download.kde.org/stable/plasma/5.15.2/breeze-plymouth-5.15.2.tar.xz.sig
- sha256sums = f093566ae51218b4461d1dbebb7a8ee402077bda2e67d840dc71309926c9d758
+ source = http://download.kde.org/stable/plasma/5.15.3/breeze-plymouth-5.15.3.tar.xz
+ source = http://download.kde.org/stable/plasma/5.15.3/breeze-plymouth-5.15.3.tar.xz.sig
+ source = breeze-plymouth.cpiohook
+ validpgpkeys = 2D1D5B0588357787DE9EE225EC94D18F7F05997E
+ validpgpkeys = 0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D
+ validpgpkeys = D07BD8662C56CB291B316EB2F5675605C74E02CF
+ validpgpkeys = 1FA881591C26B276D7A5518EEAAF29B42A678C20
+ sha256sums = 674090b5776aca915b58cfbeada45895fc51bac0e2d31509628277a2fd24c538
sha256sums = SKIP
+ sha256sums = 91a6557231d8832dcb3b6ae056742bb88467f245d22fc57fa7a5b732ee780e4c
pkgname = breeze-plymouth
diff --git a/PKGBUILD b/PKGBUILD
index d63c4ead8704..bda73beea376 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jameson Pugh <imntreal@gmail.com>
pkgname=breeze-plymouth
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
pkgdesc="Breeze theme for plymouth"
arch=(any)
@@ -9,9 +9,11 @@ url='https://projects.kde.org/breeze-plymouth'
license=(LGPL)
depends=(plymouth)
makedepends=(extra-cmake-modules)
-source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.tar.xz"{,.sig})
-sha256sums=('f093566ae51218b4461d1dbebb7a8ee402077bda2e67d840dc71309926c9d758'
- 'SKIP')
+source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.tar.xz"{,.sig}
+ 'breeze-plymouth.cpiohook')
+sha256sums=('674090b5776aca915b58cfbeada45895fc51bac0e2d31509628277a2fd24c538'
+ 'SKIP'
+ '91a6557231d8832dcb3b6ae056742bb88467f245d22fc57fa7a5b732ee780e4c')
validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell
'0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
'D07BD8662C56CB291B316EB2F5675605C74E02CF' # David Edmundson
@@ -30,4 +32,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}" install
+
+ install -dm755 "${pkgdir}/etc/initcpio/install"
+ install -m644 "${srcdir}/breeze-plymouth.cpiohook" "${pkgdir}/etc/initcpio/install/breeze-plymouth"
}
diff --git a/breeze-plymouth.cpiohook b/breeze-plymouth.cpiohook
new file mode 100644
index 000000000000..5cda4120b958
--- /dev/null
+++ b/breeze-plymouth.cpiohook
@@ -0,0 +1,49 @@
+#!/bin/bash
+
+build() {
+ # Add Plymouth plugin 'label.so'.
+ PLYMOUTH_PLUGIN_PATH="$(plymouth --get-splash-plugin-path)"
+ PLYMOUTH_MODULE_NAME="label.so"
+
+ if [[ -f "${PLYMOUTH_PLUGIN_PATH}/${PLYMOUTH_MODULE_NAME}" ]]; then
+ add_binary "${PLYMOUTH_PLUGIN_PATH}/${PLYMOUTH_MODULE_NAME}"
+ else
+ echo "The plymouth plugin (${PLYMOUTH_MODULE_NAME}) doesn't exist!" > /dev/stderr
+ exit 1
+ fi
+
+ font_config_path="/etc/fonts"
+ font_confd_path="/etc/fonts/conf.avail"
+ noto_font_path="/usr/share/fonts/noto"
+
+ # Add font configuration files.
+ add_file "${font_config_path}/fonts.conf"
+ add_dir "/var/cache/fontconfig"
+
+ # Add Noto Sans font.
+ if [[ -e "${noto_font_path}/NotoSans-Regular.ttf" && -e "${font_confd_path}/66-noto-sans.conf" ]]; then
+ add_file "${noto_font_path}/NotoSans-Regular.ttf"
+ add_file "${font_confd_path}/66-noto-sans.conf" "${font_config_path}/conf.d/66-noto-sans.conf"
+ else
+ echo "The system is missing the Noto Sans font!" > /dev/stderr
+ exit 1
+ fi
+
+ # Add Noto Serif font.
+ if [[ -e "${noto_font_path}/NotoSerif-Regular.ttf" && -e "${font_confd_path}/66-noto-serif.conf" ]]; then
+ add_file "${noto_font_path}/NotoSerif-Regular.ttf"
+ add_file "${font_confd_path}/66-noto-serif.conf" "${font_config_path}/conf.d/66-noto-serif.conf"
+ else
+ echo "The system is missing the Noto Serif font!" > /dev/stderr
+ exit 1
+ fi
+}
+
+help() {
+ cat <<HELPEOF
+This hook includes all necessary font related files and the additional plymouth
+plugin (label.so) into the initramfs image. Used by the breeze-plymouth theme.
+HELPEOF
+}
+
+# vim: set ft=sh ts=4 sw=4 et: