summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Phillips2016-02-11 02:38:14 +1300
committerDavid Phillips2016-02-11 02:38:19 +1300
commitaf144126a2c9d4da48ef25483ad6021dd37f99c2 (patch)
tree9bd4a9b4c38aa953a1087e84915517e32dca6fba
downloadaur-af144126a2c9d4da48ef25483ad6021dd37f99c2.tar.gz
Initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..152a1beb8aae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 13:37:10 UTC 2016
+pkgbase = brewtarget
+ pkgdesc = Beer calculator compatible with BeerSmith. Generates instructions from the recipe and interactive mash designer.
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = http://www.brewtarget.org/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ license = WTFPL-2
+ makedepends = cmake
+ depends = qt5-tools
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = phonon
+ conflicts = brewtarget-git
+ source = brewtarget-2.3.0.zip::https://github.com/Brewtarget/brewtarget/archive/v2.3.0.zip
+ md5sums = SKIP
+
+pkgname = brewtarget
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f9e0cd37f9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ricardo Leuck <leuck.r at gmail>
+pkgname=brewtarget
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Beer calculator compatible with BeerSmith. Generates instructions from the recipe and interactive mash designer."
+url="http://www.brewtarget.org/"
+arch=('x86_64' 'i686')
+license=('GPL3'
+ 'WTFPL-2')
+depends=('qt5-tools' 'qt5-multimedia' 'qt5-svg' 'phonon')
+optdepends=()
+makedepends=('cmake')
+conflicts=("${pkgname}-git")
+backup=()
+source=("${pkgname}-${pkgver}.zip"::"https://github.com/Brewtarget/${pkgname}/archive/v${pkgver}.zip")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING.GPLv3 "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.GPLv3"
+}