summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSiavash Askari Nasr2022-10-06 11:51:14 +0330
committerSiavash Askari Nasr2022-10-06 12:21:25 +0330
commit6c32084d4b3c150d92fd01bd55c849ce466382b7 (patch)
treeaa500a92d897c6d2e37a1e2f688ca8af918192af
downloadaur-6c32084d4b3c150d92fd01bd55c849ce466382b7.tar.gz
First release
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD66
-rw-r--r--briar-desktop-nightly.desktop8
-rw-r--r--briar-desktop.svg98
-rw-r--r--briar128.pngbin0 -> 3917 bytes
-rw-r--r--briar16.pngbin0 -> 695 bytes
-rw-r--r--briar192.pngbin0 -> 5846 bytes
-rw-r--r--briar32.pngbin0 -> 1226 bytes
-rw-r--r--briar48.pngbin0 -> 1674 bytes
-rw-r--r--briar64.pngbin0 -> 1960 bytes
-rwxr-xr-xprepare_pkg.sh7
12 files changed, 211 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85f50dd8e39d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = briar-desktop-nightly-bin
+ pkgdesc = Prototyping the next generation for Briar on desktop devices
+ pkgver = 22807
+ pkgrel = 1
+ url = https://code.briarproject.org/briar/briar-desktop
+ arch = any
+ license = AGPL3
+ depends = java-runtime>=17
+ depends = bash
+ provides = briar-desktop-nightly
+ noextract = briar-desktop-nightly.jar
+ source = briar-desktop-nightly.jar::https://code.briarproject.org/briar/briar-desktop/-/jobs/artifacts/main/raw/briar-desktop.jar?job=b_jar
+ source = briar-desktop.svg
+ source = briar16.png
+ source = briar32.png
+ source = briar48.png
+ source = briar64.png
+ source = briar128.png
+ source = briar192.png
+ source = briar-desktop-nightly.desktop
+ sha256sums = 308f1b578fd8d20a1cc19e8e1cc90dba6f49a54a39dafe9d81f0b79a92ce4b46
+ sha256sums = 95400a8578272600e0b350c4b664c09631c737ce11e750faefe27473460d7923
+ sha256sums = 965d7c617e345b809f84c8bf73d9cb0acaf763c16a4b367698218b90c1c92669
+ sha256sums = 3feb96f9b9c01085170a44fdbf8bca43b1e586fe3b68dab37fb5cb9fd4ca1fa6
+ sha256sums = 3ba1a6a3561f3b879d8295cf3397bda6c7710f138f6cbd7effe4f650765610a0
+ sha256sums = 25eb65911af5e85d193e0d60418757a2ffe7b3d7d9d3debc41259bc0503972a7
+ sha256sums = 2a3e508279c2a440372bf73da2c4acf56a9b7a0bcad886a74863f5a723413a93
+ sha256sums = a00d60b7aa59fb573c2e42f8bb4c23eb7038c91ea5ced47ebf9d537e3f3925cf
+ sha256sums = db1a6d2c1ee5dc3f8571642e092d6a2182f0595398d676d23c278d5d084f4743
+
+pkgname = briar-desktop-nightly-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e47485a64b47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Siavash Askari Nasr <ciavash@protonmail.com>
+
+_app_name=briar-desktop
+_app_nightly_name="${_app_name}-nightly"
+pkgname="${_app_nightly_name}-bin"
+pkgver=22807
+pkgrel=1
+pkgdesc="Prototyping the next generation for Briar on desktop devices"
+arch=('any')
+url='https://code.briarproject.org/briar/briar-desktop'
+license=('AGPL3')
+provides=("${_app_nightly_name}")
+depends=('java-runtime>=17' 'bash')
+_jar_source="https://code.briarproject.org/briar/${_app_name}/-/jobs/artifacts/main/raw/${_app_name}.jar?job=b_jar"
+source=("${_app_nightly_name}.jar::${_jar_source}"
+ "${_app_name}.svg"
+ "briar16.png"
+ "briar32.png"
+ "briar48.png"
+ "briar64.png"
+ "briar128.png"
+ "briar192.png"
+ "${_app_nightly_name}.desktop")
+noextract=("${_app_nightly_name}.jar")
+sha256sums=('308f1b578fd8d20a1cc19e8e1cc90dba6f49a54a39dafe9d81f0b79a92ce4b46'
+ '95400a8578272600e0b350c4b664c09631c737ce11e750faefe27473460d7923'
+ '965d7c617e345b809f84c8bf73d9cb0acaf763c16a4b367698218b90c1c92669'
+ '3feb96f9b9c01085170a44fdbf8bca43b1e586fe3b68dab37fb5cb9fd4ca1fa6'
+ '3ba1a6a3561f3b879d8295cf3397bda6c7710f138f6cbd7effe4f650765610a0'
+ '25eb65911af5e85d193e0d60418757a2ffe7b3d7d9d3debc41259bc0503972a7'
+ '2a3e508279c2a440372bf73da2c4acf56a9b7a0bcad886a74863f5a723413a93'
+ 'a00d60b7aa59fb573c2e42f8bb4c23eb7038c91ea5ced47ebf9d537e3f3925cf'
+ 'db1a6d2c1ee5dc3f8571642e092d6a2182f0595398d676d23c278d5d084f4743')
+
+pkgver() {
+ local build_job_number=$(curl -I -s "${_jar_source}" | grep -E ^location: | grep -E -o '[[:digit:]]+')
+ echo -n "${build_job_number}"
+}
+
+package() {
+ install -dm755 "$pkgdir/usr/bin/"
+ cat << EOF > "$pkgdir/usr/bin/${_app_nightly_name}"
+#!/bin/sh
+exec /usr/bin/env java -jar '/usr/share/java/briar-desktop-nightly.jar' "\$@"
+EOF
+ chmod +x "$pkgdir/usr/bin/${_app_nightly_name}"
+
+ install -m 644 -D "${_app_nightly_name}.jar" "$pkgdir/usr/share/java/${_app_nightly_name}.jar"
+
+ install -C -Dm644 "${srcdir}/${_app_name}.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/${_app_nightly_name}.svg"
+
+ # Taken from briar-desktop-bin/briar-desktop-git
+ # generated with inkscape from the svg
+ # just seemed unreasonable to require inkscape as a makedep
+ # for size in 16 32 48 64 128 192; do
+ # inkscape --export-background-opacity=0 \
+ # --export-width=${size} --export-type=png \
+ # --export-filename=${size}.png briar-desktop.svg
+ # done
+
+ for i in 16 32 48 64 128 192; do
+ install -C -Dm644 "${srcdir}/briar${i}.png" "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/${_app_nightly_name}.png"
+ done
+
+ install -Dm644 "${srcdir}/${_app_nightly_name}.desktop" "$pkgdir/usr/share/applications/${_app_nightly_name}.desktop"
+}
diff --git a/briar-desktop-nightly.desktop b/briar-desktop-nightly.desktop
new file mode 100644
index 000000000000..413026488d32
--- /dev/null
+++ b/briar-desktop-nightly.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Briar Desktop Nightly
+Comment=Secure messaging, anywhere
+Exec=/usr/bin/briar-desktop-nightly %u
+Icon=briar-desktop-nightly
+Terminal=false
+Type=Application
+Categories=Network;Chat;InstantMessaging;
diff --git a/briar-desktop.svg b/briar-desktop.svg
new file mode 100644
index 000000000000..20b6cabbbc45
--- /dev/null
+++ b/briar-desktop.svg
@@ -0,0 +1,98 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ version="1.1"
+ id="Ebene_1"
+ x="0px"
+ y="0px"
+ viewBox="0 0 330.00001 330.00001"
+ xml:space="preserve"
+ inkscape:version="0.92.5 (2060ec1f9f, 2020-04-08)"
+ sodipodi:docname="logo_circle.svg"
+ width="330"
+ height="330"><metadata
+ id="metadata61"><rdf:RDF><cc:Work
+ rdf:about=""><dc:format>image/svg+xml</dc:format><dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" /><dc:title></dc:title></cc:Work></rdf:RDF></metadata><defs
+ id="defs59" /><sodipodi:namedview
+ pagecolor="#000000"
+ bordercolor="#666666"
+ borderopacity="1"
+ objecttolerance="10"
+ gridtolerance="10"
+ guidetolerance="10"
+ inkscape:pageopacity="0"
+ inkscape:pageshadow="2"
+ inkscape:window-width="1680"
+ inkscape:window-height="993"
+ id="namedview57"
+ showgrid="false"
+ inkscape:zoom="1.2101234"
+ inkscape:cx="50.121881"
+ inkscape:cy="156.73039"
+ inkscape:window-x="0"
+ inkscape:window-y="0"
+ inkscape:window-maximized="1"
+ inkscape:current-layer="Ebene_1" /><style
+ type="text/css"
+ id="style3">
+ .st0{fill:#FFFFFF;}
+ .st1{display:none;fill:#87C214;}
+ .st2{fill:#87C214;}
+ .st3{display:none;fill:#FFFFFF;}
+ .st4{fill:#95D220;}
+ .st5{display:none;fill:#95D220;}
+</style><circle
+ style="fill:#ffffff"
+ id="circle7"
+ cy="165"
+ cx="165"
+ class="st0"
+ r="165" /><g
+ id="g1059"><path
+ class="st2"
+ d="m 94.299994,145.70001 v 119.5 c 0,9.7 7.899996,17.7 17.699996,17.7 h 8.3 c 9.7,0 17.7,-8 17.7,-17.7 v -119.5 z"
+ id="path15"
+ inkscape:connector-curvature="0"
+ style="fill:#87c214" /><path
+ class="st2"
+ d="m 137.99999,88.000006 v -22.5 c 0,-9.7 -8,-17.7 -17.7,-17.7 h -8.3 c -9.7,0 -17.699996,8 -17.699996,17.7 v 22.5 z"
+ id="path17"
+ inkscape:connector-curvature="0"
+ style="fill:#87c214" /><path
+ class="st2"
+ d="M 234.99999,185.00001 V 65.500006 c 0,-9.7 -7.9,-17.7 -17.7,-17.7 h -8.3 c -9.7,0 -17.7,8 -17.7,17.7 V 185.00001 Z"
+ id="path25"
+ inkscape:connector-curvature="0"
+ style="fill:#87c214" /><path
+ class="st2"
+ d="m 191.29999,242.70001 v 22.5 c 0,9.7 8,17.7 17.7,17.7 h 8.3 c 9.7,0 17.7,-8 17.7,-17.7 v -22.5 z"
+ id="path29"
+ inkscape:connector-curvature="0"
+ style="fill:#87c214" /><path
+ class="st4"
+ d="m 87.299994,192.00001 h -22.5 c -9.7,0 -17.7,7.9 -17.7,17.7 v 8.3 c 0,9.7 7.9,17.7 17.7,17.7 h 22.5 z"
+ id="path37"
+ inkscape:connector-curvature="0"
+ style="fill:#95d220" /><path
+ class="st4"
+ d="m 264.49999,192.00001 h -119.5 v 43.7 h 119.5 c 9.7,0 17.7,-8 17.7,-17.7 v -8.3 c -0.1,-9.7 -8,-17.7 -17.7,-17.7 z"
+ id="path41"
+ inkscape:connector-curvature="0"
+ style="fill:#95d220" /><path
+ class="st4"
+ d="M 184.29999,95.000006 H 64.799994 c -9.7,0 -17.7,7.900004 -17.7,17.700004 v 8.3 c 0,9.7 7.9,17.7 17.7,17.7 H 184.29999 Z"
+ id="path51"
+ inkscape:connector-curvature="0"
+ style="fill:#95d220" /><path
+ class="st4"
+ d="m 264.49999,95.000006 h -22.5 v 43.700004 h 22.5 c 9.7,0 17.7,-7.9 17.7,-17.7 v -8.3 c -0.1,-9.7 -8,-17.700004 -17.7,-17.700004 z"
+ id="path53"
+ inkscape:connector-curvature="0"
+ style="fill:#95d220" /></g></svg>
diff --git a/briar128.png b/briar128.png
new file mode 100644
index 000000000000..fce3de2f685a
--- /dev/null
+++ b/briar128.png
Binary files differ
diff --git a/briar16.png b/briar16.png
new file mode 100644
index 000000000000..f06016b368ba
--- /dev/null
+++ b/briar16.png
Binary files differ
diff --git a/briar192.png b/briar192.png
new file mode 100644
index 000000000000..475670c83f5a
--- /dev/null
+++ b/briar192.png
Binary files differ
diff --git a/briar32.png b/briar32.png
new file mode 100644
index 000000000000..158e66b7ea51
--- /dev/null
+++ b/briar32.png
Binary files differ
diff --git a/briar48.png b/briar48.png
new file mode 100644
index 000000000000..e419e98cbba5
--- /dev/null
+++ b/briar48.png
Binary files differ
diff --git a/briar64.png b/briar64.png
new file mode 100644
index 000000000000..ffd2257d4fe4
--- /dev/null
+++ b/briar64.png
Binary files differ
diff --git a/prepare_pkg.sh b/prepare_pkg.sh
new file mode 100755
index 000000000000..b050b8e9150d
--- /dev/null
+++ b/prepare_pkg.sh
@@ -0,0 +1,7 @@
+#!/usr/bin/env bash
+
+updpkgsums
+
+makepkg --printsrcinfo > .SRCINFO
+
+makepkg --install