summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuglloc2015-06-17 11:34:34 +0200
committerBuglloc2015-06-17 11:34:34 +0200
commiteafb36074d31bccf7c01924967a6e58c0b679ded (patch)
treef917118eca75336af5cb499cf8dc7ca737bf2394
downloadaur-eafb36074d31bccf7c01924967a6e58c0b679ded.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
-rw-r--r--brick.install44
3 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04c3104e8f1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = brick
+ pkgdesc = Unofficial Bitrix24 messenger client
+ pkgver = 0.1.26.31
+ pkgrel = 1
+ url = https://github.com/buglloc/brick
+ install = brick.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = p7zip
+ makedepends = cmake
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = gconf
+ depends = libxtst
+ depends = libxss
+ depends = xdg-utils
+ depends = gtk2
+ depends = libnotify
+ depends = nss
+ conflicts = brick-unity
+ conflicts = brick-git
+ conflicts = brick-unity-git
+ source = https://github.com/buglloc/brick/archive/v0.1.26.31.tar.gz
+ sha256sums = f96affeb0d2270057f81e0123376c1830539d8a3c69efb3cc4dde0b5bf6459b2
+ source_i686 = https://github.com/buglloc/cef-builds/raw/79c6f03ac3d4eb3332d6c374d9a9cb0fa3be742b/libs/cef-i686.tar.gz
+ sha256sums_i686 = 134454435e24ecae8be9430cb36e2a6095f780443e2e09ac05a4e41beb85d253
+
+pkgname = brick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c958b6bb0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Andrew Krasichkov <buglloc _ at _ yandex _ dot _ru>
+
+pkgname=brick
+pkgver=0.1.26.31
+pkgrel=1
+pkgdesc="Unofficial Bitrix24 messenger client"
+arch=('i686' 'x86_64')
+url="https://github.com/buglloc/brick"
+license=("MIT")
+depends=("alsa-lib" "desktop-file-utils" "gconf" "libxtst" "libxss" "xdg-utils" "gtk2" "libnotify" "nss")
+optdepends=()
+conflicts=("brick-unity" "brick-git" "brick-unity-git")
+makedepends=("p7zip" "cmake")
+install=${pkgname}.install
+source=("https://github.com/buglloc/brick/archive/v${pkgver}.tar.gz")
+source_i686=("https://github.com/buglloc/cef-builds/raw/79c6f03ac3d4eb3332d6c374d9a9cb0fa3be742b/libs/cef-i686.tar.gz")
+sha256sums=("f96affeb0d2270057f81e0123376c1830539d8a3c69efb3cc4dde0b5bf6459b2")
+sha256sums_i686=("134454435e24ecae8be9430cb36e2a6095f780443e2e09ac05a4e41beb85d253")
+
+
+build() {
+ cd ${srcdir}
+
+ if [ $CARCH == "i686" ];
+ then
+ rm -f "brick-${pkgver}/Release/*"
+ cp -arf cef-i686/* "brick-${pkgver}/Release"
+ fi
+
+ mkdir -p out
+ cd out
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir} -DUNITY_DESKTOP=OFF "../brick-${pkgver}"
+ make
+}
+
+package() {
+ cd ${srcdir}/out
+ make install
+ install -dm755 "${pkgdir}/usr/bin"
+ rm -f "${pkgdir}/usr/bin/brick"
+ ln -s /opt/brick/brick "${pkgdir}/usr/bin/brick"
+}
diff --git a/brick.install b/brick.install
new file mode 100644
index 000000000000..69b302cf2828
--- /dev/null
+++ b/brick.install
@@ -0,0 +1,44 @@
+post_install() {
+ if [ ! -f /opt/brick/libnss3.so.1d ]; then
+ ln -s /usr/lib/libnss3.so /opt/brick/libnss3.so.1d
+ fi
+ if [ ! -f /opt/brick/libnssutil3.so.1d ]; then
+ ln -s /usr/lib/libnssutil3.so /opt/brick/libnssutil3.so.1d
+ fi
+ if [ ! -f /opt/brick/libnspr4.so.0d ]; then
+ ln -s /usr/lib/libnspr4.so /opt/brick/libnspr4.so.0d
+ fi
+ if [ ! -f /opt/brick/libplc4.so.0d ]; then
+ ln -s /usr/lib/libplc4.so /opt/brick/libplc4.so.0d
+ fi
+ if [ ! -f /opt/brick/libsmime3.so.1d ]; then
+ ln -s /usr/lib/libsmime3.so /opt/brick/libsmime3.so.1d
+ fi
+ if [ ! -f /opt/brick/libssl3.so.1d ]; then
+ ln -s /usr/lib/libssl3.so /opt/brick/libssl3.so.1d
+ fi
+ if [ ! -f /opt/brick/libplds4.so.0d ]; then
+ ln -s /usr/lib/libplds4.so /opt/brick/libplds4.so.0d
+ fi
+
+ for icon in "/opt/brick/resources/app_icons/brick"*.png; do
+ size="${icon##*/brick}"
+ xdg-icon-resource install --novendor --size "${size%.png}" "$icon" "brick" &> /dev/null
+ done
+
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ desktop-file-install /opt/brick/brick.desktop
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove(){
+ rm /opt/bick/{libnss3.so.1d,libnssutil3.so.1d,libnspr4.so.0d,libplc4.so.0d,libsmime3.so.1d,libssl3.so.1d,libplds4.so.0d}
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}