summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Delacourt2015-06-11 21:30:51 +0200
committerGuillaume Delacourt2015-06-11 21:30:51 +0200
commit85b08e0d0f8468260cfd6cae7c2c3b748cd2076c (patch)
tree3acf7d73d2b998d3fb7ba76d668c4055c9cca189
downloadaur-85b08e0d0f8468260cfd6cae7c2c3b748cd2076c.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rwxr-xr-xbrickshooter2
-rw-r--r--brickshooter.desktop9
-rw-r--r--brickshooter.pngbin0 -> 387 bytes
5 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..411318fca021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = brickshooter
+ pkgdesc = A small puzzle game where you'll have to clear the central area from blocks.
+ pkgver = 0.04
+ pkgrel = 2
+ url = http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Puzzle/brickshooter-37619.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl
+ depends = sdl_mixer
+ depends = sdl_image
+ source = http://mirror.amdmi3.ru/distfiles/brickshooter-0.04.tar.gz
+ source = brickshooter
+ source = brickshooter.desktop
+ source = brickshooter.png
+ md5sums = 9b2308e44591917b8d1f0b0382b7e878
+ md5sums = 2cc6383a4dec9ef7ca40a8c09d27bea8
+ md5sums = fccfdb36a7499184849a86410e9b3a46
+ md5sums = d3ad3f00689b0422c6db3ef9359c1acc
+
+pkgname = brickshooter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48d2e7a85b9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Feufochmar <feufochmar.gd@gmail.com>
+pkgname=brickshooter
+pkgver=0.04
+pkgrel=2
+pkgdesc="A small puzzle game where you'll have to clear the central area from blocks."
+arch=('i686' 'x86_64')
+url="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Puzzle/brickshooter-37619.shtml"
+license=('GPL')
+depends=('sdl' 'sdl_mixer' 'sdl_image')
+source=("http://mirror.amdmi3.ru/distfiles/$pkgname-$pkgver.tar.gz"
+ 'brickshooter'
+ 'brickshooter.desktop'
+ 'brickshooter.png')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ # There is no "make install" in the makefile...
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d "$pkgdir/usr/share/brickshooter/"{gfx,levels,snd}
+ install -d "$pkgdir/usr/bin" "$pkgdir/usr/share/applications" "$pkgdir/usr/share/pixmaps"
+ install -m 755 brickshooter "$pkgdir/usr/share/brickshooter"
+ install -m 644 gfx/* "$pkgdir/usr/share/brickshooter/gfx"
+ install -m 644 levels/* "$pkgdir/usr/share/brickshooter/levels"
+ install -m 644 snd/* "$pkgdir/usr/share/brickshooter/snd"
+ cd "$srcdir"
+ install -m 755 brickshooter "$pkgdir/usr/bin"
+ install -m 644 brickshooter.desktop "$pkgdir/usr/share/applications"
+ install -m 644 brickshooter.png "$pkgdir/usr/share/pixmaps"
+}
+md5sums=('9b2308e44591917b8d1f0b0382b7e878'
+ '2cc6383a4dec9ef7ca40a8c09d27bea8'
+ 'fccfdb36a7499184849a86410e9b3a46'
+ 'd3ad3f00689b0422c6db3ef9359c1acc')
diff --git a/brickshooter b/brickshooter
new file mode 100755
index 000000000000..a8fb8c7967ba
--- /dev/null
+++ b/brickshooter
@@ -0,0 +1,2 @@
+#! /bin/sh
+cd /usr/share/brickshooter && ./brickshooter
diff --git a/brickshooter.desktop b/brickshooter.desktop
new file mode 100644
index 000000000000..a16b862be8e7
--- /dev/null
+++ b/brickshooter.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Brickshooter
+Exec=brickshooter
+TryExec=brickshooter
+Icon=brickshooter
+Comment=A puzzle game where you'll have to clear an area from bricks.
+Terminal=false
+Type=Application
+Categories=Game;LogicGame; \ No newline at end of file
diff --git a/brickshooter.png b/brickshooter.png
new file mode 100644
index 000000000000..667887a76ab6
--- /dev/null
+++ b/brickshooter.png
Binary files differ