diff options
author | Marcus Klein | 2022-09-15 07:52:58 +0200 |
---|---|---|
committer | Marcus Klein | 2022-09-15 09:34:22 +0200 |
commit | 629e673e589a79beee784bf8094d8a1603f924da (patch) | |
tree | c9b04f1213dd3d7fb68425db81f39460ddba9a25 | |
parent | 2f46667fb635f4a4294efe0b2f809675fbe27899 (diff) | |
download | aur-629e673e589a79beee784bf8094d8a1603f924da.tar.gz |
brickstore 2022.9.x releases are now Qt6 based
and build needs to be adapted accordingly
-rw-r--r-- | PKGBUILD | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -7,18 +7,18 @@ pkgdesc="BrickStore is a BrickLink offline management tool." arch=('i686' 'x86_64') url="https://github.com/rgriebl/brickstore" license=('GPL') -depends=('qt5-base' 'tbb') -makedepends=('qt5-tools' 'qt5-translations') +depends=('qt6-base' 'qt6-quick3d' 'qt6-shadertools') +makedepends=('cmake' 'ninja') source=("https://github.com/rgriebl/brickstore/archive/v$pkgver.tar.gz") sha256sums=('ebfbe3dc9f60f8ca6ffb7751a45012b93a241ac043ec303d4c9e72459e5e3a7c') build() { cd "$pkgname-$pkgver" - qmake-qt5 -r PREFIX=/usr CONFIG+=release - make + /usr/lib/qt6/bin/qt-cmake -G Ninja -DCMAKE_BUILD_TYPE=Release + cmake --build . --config Release --parallel } package() { cd "$pkgname-$pkgver" - make INSTALL_ROOT="$pkgdir/" install + DESTDIR="$pkgdir/" cmake --install . -v } |