summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2020-06-03 20:32:00 +0200
committerhashworks2020-06-03 20:32:00 +0200
commit3cd7bf8766f148cbbb905c7ef28b174d56e33543 (patch)
tree8eadfdbacefa20089c71dd5b5db200982d3aad46
parentc744310984a7c3913c27d19dae80d72d0c5d3f6c (diff)
downloadaur-3cd7bf8766f148cbbb905c7ef28b174d56e33543.tar.gz
PKGBUILD improvements
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9aef35912467..50a0a9a5b4aa 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = brickstrap-git
- pkgdesc = Tool for bootstrapping Debian and creating bootable image files for embedded systems
+ pkgdesc = Tool for turning Docker images into bootable image files for embedded systems
pkgver = 0.6.8.r4.ga48aea5
pkgrel = 1
url = https://github.com/ev3dev/brickstrap
@@ -9,7 +9,7 @@ pkgbase = brickstrap-git
depends = libguestfs
optdepends = qemu-arm-static: Build arm images (f.e. LEGO ev3 bricks)
source = git+https://github.com/ev3dev/brickstrap.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = brickstrap-git
diff --git a/PKGBUILD b/PKGBUILD
index 69b3bf7f4c4f..5634e8aec619 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
pkgname=brickstrap-git
pkgver=0.6.8.r4.ga48aea5
pkgrel=1
-pkgdesc='Tool for bootstrapping Debian and creating bootable image files for embedded systems'
+pkgdesc='Tool for turning Docker images into bootable image files for embedded systems'
url='https://github.com/ev3dev/brickstrap'
license=('MIT')
arch=('any')
depends=('docker' 'libguestfs')
optdepends=('qemu-arm-static: Build arm images (f.e. LEGO ev3 bricks)')
-source=('git+https://github.com/ev3dev/brickstrap.git')
-md5sums=('SKIP')
+source=("git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
- cd "brickstrap"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "brickstrap"
- install -Dm755 src/brickstrap.sh $pkgdir/usr/bin/brickstrap
+ cd "${pkgname%-git}"
+ install -Dm755 src/brickstrap.sh "${pkgdir}/usr/bin/brickstrap"
}