summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2020-04-22 12:39:24 +0200
committerhashworks2020-04-22 12:39:24 +0200
commitc744310984a7c3913c27d19dae80d72d0c5d3f6c (patch)
tree41337cc3a41a225caea355d2ba3a63589751c2df
parentebd6a4026d892bdbf36700a2a16c5c72c6c8ba52 (diff)
downloadaur-c744310984a7c3913c27d19dae80d72d0c5d3f6c.tar.gz
Use git tag versioning
-rwxr-xr-x[-rw-r--r--].SRCINFO4
-rw-r--r--.gitignore2
-rwxr-xr-x[-rw-r--r--]PKGBUILD6
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5f8a2323477..9aef35912467 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = brickstrap-git
- pkgdesc = Tool for bootstrapping Debian and creating bootable image files for embedded systems, f.e. ev3dev
- pkgver = r32.69925f0
+ pkgdesc = Tool for bootstrapping Debian and creating bootable image files for embedded systems
+ pkgver = 0.6.8.r4.ga48aea5
pkgrel = 1
url = https://github.com/ev3dev/brickstrap
arch = any
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b923c2d7997d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+brickstrap/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 37837fc33e2e..69b3bf7f4c4f 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: hashworks <mail@hashworks.net>
pkgname=brickstrap-git
-pkgver=r32.69925f0
+pkgver=0.6.8.r4.ga48aea5
pkgrel=1
-pkgdesc='Tool for bootstrapping Debian and creating bootable image files for embedded systems, f.e. ev3dev'
+pkgdesc='Tool for bootstrapping Debian and creating bootable image files for embedded systems'
url='https://github.com/ev3dev/brickstrap'
license=('MIT')
arch=('any')
@@ -14,7 +14,7 @@ md5sums=('SKIP')
pkgver() {
cd "brickstrap"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {