summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2017-09-05 16:44:06 +0200
committerhashworks2017-09-05 16:44:06 +0200
commitebd6a4026d892bdbf36700a2a16c5c72c6c8ba52 (patch)
tree36c623f9da72e25a2bce9eb1b125de3514df68aa
downloadaur-ebd6a4026d892bdbf36700a2a16c5c72c6c8ba52.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5f8a2323477
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = brickstrap-git
+ pkgdesc = Tool for bootstrapping Debian and creating bootable image files for embedded systems, f.e. ev3dev
+ pkgver = r32.69925f0
+ pkgrel = 1
+ url = https://github.com/ev3dev/brickstrap
+ arch = any
+ license = MIT
+ depends = docker
+ depends = libguestfs
+ optdepends = qemu-arm-static: Build arm images (f.e. LEGO ev3 bricks)
+ source = git+https://github.com/ev3dev/brickstrap.git
+ md5sums = SKIP
+
+pkgname = brickstrap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37837fc33e2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: hashworks <mail@hashworks.net>
+
+pkgname=brickstrap-git
+pkgver=r32.69925f0
+pkgrel=1
+pkgdesc='Tool for bootstrapping Debian and creating bootable image files for embedded systems, f.e. ev3dev'
+url='https://github.com/ev3dev/brickstrap'
+license=('MIT')
+arch=('any')
+depends=('docker' 'libguestfs')
+optdepends=('qemu-arm-static: Build arm images (f.e. LEGO ev3 bricks)')
+source=('git+https://github.com/ev3dev/brickstrap.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "brickstrap"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "brickstrap"
+ install -Dm755 src/brickstrap.sh $pkgdir/usr/bin/brickstrap
+}