summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 22:02:24 +0200
committeroli2015-06-12 22:02:24 +0200
commitb882c57c763899cf3038cd8a65cc97b5c893074e (patch)
treef427f32e4ac0ae04d1f01d9e9f92aa321e77cd3f
downloadaur-b882c57c763899cf3038cd8a65cc97b5c893074e.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10b8b7e8d1c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brickv
+ pkgdesc = brick viewer is a testing/flashing tool for tinkerforge brick(let)s
+ pkgver = 2.2.4
+ pkgrel = 3
+ url = http://www.tinkerforge.com/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL2
+ depends = pyqwt
+ depends = python2-pyserial
+ depends = brickd
+ depends = python-pyqt4
+ depends = python2-setuptools
+ optdepends = brickd
+ source = https://github.com/Tinkerforge/brickv/archive/v2.2.4.zip
+ md5sums = d04008b969411126bf1250eef2022549
+
+pkgname = brickv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d665cae4cec3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=brickv
+pkgver=2.2.4
+pkgrel=3
+pkgdesc="brick viewer is a testing/flashing tool for tinkerforge brick(let)s"
+url="http://www.tinkerforge.com/"
+license=("GPL2")
+arch=('i686' 'x86_64' 'armv7h')
+depends=('pyqwt' 'python2-pyserial' 'brickd' 'python-pyqt4' 'python2-setuptools')
+optdepends=('brickd')
+source=(https://github.com/Tinkerforge/${pkgname}/archive/v${pkgver}.zip)
+md5sums=('d04008b969411126bf1250eef2022549')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver/src/
+ python2 setup.py config
+ python2 setup.py build
+ cd brickv/plugin_system/plugins
+ for i in */build_ui.py; do cd $(dirname $i); ./build_ui.py; cd ..; done
+ cd ../..
+ python2 ./build_ui.py
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver/src/
+ python2 setup.py install --root=$pkgdir --prefix=/usr
+}