summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Henderson2020-01-04 14:07:16 +0000
committerJames Henderson2020-01-04 14:07:16 +0000
commite70b3dabeea47f19c157e3138b730554147efb8a (patch)
tree9a33179f83ca28685a6949adcbe831f8a3a78ed3
parent6f05eeb0084f535317837ece4de9866c247b1e1d (diff)
downloadaur-e70b3dabeea47f19c157e3138b730554147efb8a.tar.gz
actually building Bridje
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12a3c77d39f0..f38bda29143c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,10 @@ pkgbase = bridje-bin
pkgrel = 1
url = https://github.com/bridje/bridje
arch = x86_64
- license = EPL
+ license = custom
+ depends = jdk11-graalvm-bin
+ source = https://github.com/bridje/bridje/releases/download/v0.0.0/bridje-component-0.0.0.jar
+ sha256sums = fa21c0a4eaccdc89238a9b22db5fa266e50eb8b0824b3c5d41e1f80e420a2e44
pkgname = bridje-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3ce22c55514c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.xz
+/*.jar
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index e9b6a41e45bf..8ab0ae325111 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,6 +5,16 @@ pkgrel=1
pkgdesc="Bridje is a statically typed LISP targeting GraalVM, drawing inspiration from both Clojure and Haskell."
arch=('x86_64')
url="https://github.com/bridje/bridje"
-license=('EPL')
-depends=()
-install=
+license=('custom')
+depends=('jdk11-graalvm-bin')
+
+source=("https://github.com/bridje/bridje/releases/download/v${pkgver}/bridje-component-${pkgver}.jar")
+sha256sums=('fa21c0a4eaccdc89238a9b22db5fa266e50eb8b0824b3c5d41e1f80e420a2e44')
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/jvm/java-11-graalvm/bin"
+ cp -a -t "$pkgdir/usr/lib/jvm/java-11-graalvm/" languages/
+
+ chmod +x "$pkgdir/usr/lib/jvm/java-11-graalvm/languages/brj/bin/brj"
+ ln -s "$pkgdir/usr/lib/jvm/java-11-graalvm/languages/brj/bin/brj" "$pkgdir/usr/lib/jvm/java-11-graalvm/bin/brj"
+}