summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspreagtha2019-05-07 23:48:52 -0400
committerspreagtha2019-05-07 23:48:52 -0400
commitfe11fcdf75c7cc764ed5ded6dc49624134401e4e (patch)
treed6c5e993d87079396b1268b594cb50924f7cb12d
parentab9b001982ce118e14bbe657c72e7ac168a98c0a (diff)
downloadaur-fe11fcdf75c7cc764ed5ded6dc49624134401e4e.tar.gz
- Changing the base brig-git package to work with brig's latest release tarballs
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27282012227b..8647821ec2d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
-pkgbase = brig-git
- pkgdesc = File synchronization on top of ipfs with git like interface and web based UI -- development branch
- pkgver = develop
- pkgrel = 5
+pkgbase = brig
+ pkgdesc = File synchronization on top of ipfs with git like interface and web based UI
+ pkgver = 0.4.1
+ pkgrel = 1
url = https://github.com/sahib/brig
arch = x86_64
arch = i686
arch = armv7h
arch = aarch64
license = AGPLv3
- makedepends = git
depends = go
provides = brig
- source = git+https://github.com/sahib/brig
+ conflicts = brig-git
+ source = brig-0.4.1.tar.gz::https://github.com/sahib/brig/archive/v0.4.1.tar.gz
sha256sums = SKIP
-pkgname = brig-git
+pkgname = brig
diff --git a/PKGBUILD b/PKGBUILD
index e64a69a99b0f..5bb76fb049ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: Vasket <vasket at dismail dot de>
+# Maintainer: Spreagtha <spreagtha at mykolab dot com>
+# Contributor: Vasket <vasket at dismail dot de>
-pkgname="brig-git"
-_pkgname="brig"
-pkgver="develop"
-pkgrel="5"
-pkgdesc="File synchronization on top of ipfs with git like interface and web based UI -- development branch"
+pkgname="brig"
+pkgver="0.4.1"
+pkgrel="1"
+pkgdesc="File synchronization on top of ipfs with git like interface and web based UI"
arch=(x86_64 i686 armv7h aarch64)
license=("AGPLv3")
-url="https://github.com/sahib/${_pkgname}"
+url="https://github.com/sahib/${pkgname}"
depends=(go)
-makedepends=(git)
provides=("brig")
+conflicts=("brig-git")
-source=("git+https://github.com/sahib/${_pkgname}")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/sahib/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=("SKIP")
build() {
- cd "${_pkgname}"
- git checkout develop
- GOBIN="${srcdir}/${_pkgname}" go run mage.go b
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ GOBIN="${srcdir}/${pkgname}-${pkgver}" go run mage.go b
}
package() {
- cd "${_pkgname}"
- install -Dm755 "${srcdir}/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}