summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvasket2019-03-25 23:49:15 +0100
committervasket2019-03-25 23:49:15 +0100
commit2649fdb4e35139a7b6c75472e6e9908bc36f3034 (patch)
tree3c3a539818b6900acf672491a1860c9609ffd6fb
parentb8e74e7a8f213ac327b4ea90e7455069479fcb70 (diff)
downloadaur-2649fdb4e35139a7b6c75472e6e9908bc36f3034.tar.gz
switched build system due to upsteam
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0752981e7eb1..528525768567 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brig-git
pkgdesc = File synchronization on top of ipfs with git like interface and web based UI -- development branch
pkgver = develop
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/sahib/brig
arch = x86_64
arch = i686
@@ -9,7 +9,6 @@ pkgbase = brig-git
arch = aarch64
license = AGPLv3
makedepends = git
- makedepends = make
depends = go
provides = brig
source = git+https://github.com/sahib/brig
diff --git a/PKGBUILD b/PKGBUILD
index 8a5e007fc692..b57d006cb76b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname="brig-git"
_pkgname="brig"
pkgver="develop"
-pkgrel="3"
+pkgrel="4"
pkgdesc="File synchronization on top of ipfs with git like interface and web based UI -- development branch"
arch=(x86_64 i686 armv7h aarch64)
license=("AGPLv3")
url="https://github.com/sahib/${_pkgname}"
depends=(go)
-makedepends=(git make)
+makedepends=(git)
provides=("brig")
source=("git+https://github.com/sahib/${_pkgname}")
@@ -18,12 +18,11 @@ sha256sums=("SKIP")
build() {
cd "${_pkgname}"
git checkout develop
- export GOBIN=bin/
- make
+ go run mage.go
}
package() {
cd "${_pkgname}"
- install -Dm755 "${srcdir}/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${srcdir}/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}