summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-11-26 11:18:24 +0000
committerHans-Nikolai Viessmann2016-11-26 11:18:24 +0000
commit01fda724a0269d6777633fc48a3569a60206fca8 (patch)
treeba1d0ac8566fdc51ba0551d262a2f5a37ce9659d
downloadaur-01fda724a0269d6777633fc48a3569a60206fca8.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--cmgui.sh1
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b01e33d6d870
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bright-cmgui
+ pkgdesc = Bright Clusters Management GUI application
+ pkgver = 7.3
+ pkgrel = 1
+ url = http://www.brightcomputing.com/documentation
+ arch = x86_64
+ license = unknown
+ depends = firefox
+ noextract = cmgui-7.3.tar.bz2
+ source = http://support.brightcomputing.com/cmgui-download/cmgui-7.3.tar.bz2
+ source = cmgui.sh
+ md5sums = f8819cea30e1e160b1af6c86ce6329d9
+ md5sums = 005a904d7c43fdab0df2048766a00cf1
+
+pkgname = bright-cmgui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e7325104a7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 @ hw.ac.uk>
+_pkgname=cmgui
+pkgname="bright-${_pkgname}"
+pkgver=7.3
+pkgrel=1
+pkgdesc="Bright Clusters Management GUI application"
+arch=('x86_64')
+url="http://www.brightcomputing.com/documentation"
+license=('unknown')
+depends=('firefox')
+source=("http://support.brightcomputing.com/cmgui-download/${_pkgname}-${pkgver}.tar.bz2"
+ 'cmgui.sh')
+md5sums=('f8819cea30e1e160b1af6c86ce6329d9'
+ '005a904d7c43fdab0df2048766a00cf1')
+noextract=("${_pkgname}-${pkgver}.tar.bz2")
+
+package() {
+ cd "$pkgdir"
+
+ install -d "$pkgdir/opt/BrightCMGUI"
+ install -Dm755 "$srcdir/cmgui.sh" "$pkgdir/etc/profile.d/cmgui.sh"
+
+ msg2 "Extracting archive"
+ bsdtar --strip-components 1 -xjf "$srcdir/${_pkgname}-${pkgver}.tar.bz2" -C "$pkgdir/opt/BrightCMGUI"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/cmgui.sh b/cmgui.sh
new file mode 100644
index 000000000000..16b6e0d48c48
--- /dev/null
+++ b/cmgui.sh
@@ -0,0 +1 @@
+export PATH=$PATH:/opt/BrightCMGUI