summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2012-02-01 15:35:10 +0100
committerAntoine Lubineau2012-02-01 15:35:10 +0100
commit01b4e1066a47066018df2a281249fa4bdc726265 (patch)
tree563bb1a357a2cdbeb53ed5b8d20c626a7f5c681b
downloadaur-01b4e1066a47066018df2a281249fa4bdc726265.tar.gz
brighmare: new package
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD24
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9b8990964f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = brightmare
+ pkgdesc = A tool that translates LaTeX equations to ASCII/UTF-8 text
+ pkgver = 0.34.2
+ pkgrel = 1
+ url = http://jwilk.net/software/brightmare
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = ocaml
+ source = http://jwilk.net/pool/brightmare_0.34.2.tar.gz
+ sha256sums = 55b40685fabbf2bd05ec7667f2077e0bd9f0a51c665d9ac2bdd4f949bf1795c4
+
+pkgname = brightmare
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d87e7a760b0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+
+pkgname=brightmare
+pkgver=0.34.2
+pkgrel=1
+pkgdesc="A tool that translates LaTeX equations to ASCII/UTF-8 text"
+arch=('i686' 'x86_64')
+url="http://jwilk.net/software/brightmare"
+license=('GPL2')
+makedepends=('ocaml')
+source=("http://jwilk.net/pool/brightmare_$pkgver.tar.gz")
+sha256sums=('55b40685fabbf2bd05ec7667f2077e0bd9f0a51c665d9ac2bdd4f949bf1795c4')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ install -D -m 0755 "$srcdir/$pkgname-$pkgver/brightmare" "$pkgdir/usr/bin/brightmare"
+ ln -s /usr/bin/brightmare "$pkgdir/usr/bin/brightmare-html"
+}
+
+# vim:set ts=2 sw=2 et: