summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-12-14 09:59:00 -0700
committerMark Wagie2023-12-14 09:59:00 -0700
commite673c36efaa5f9533e38cbcccf65d13234a5923a (patch)
treec1175856b4e00b38ff7546a52e3b4b7f8057b6d9
parent8d9decd380a1b25e3b4da5e0c74388427ee2b04c (diff)
downloadaur-e673c36efaa5f9533e38cbcccf65d13234a5923a.tar.gz
specify GIT_DIR and restore .gitignore
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c49b80a2168a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!brightness-controller.desktop
+!brightness-reset.sh
diff --git a/PKGBUILD b/PKGBUILD
index 84fec2fda967..2d7e2be3ec37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,22 +21,22 @@ sha256sums=('SKIP'
'995a513671b4d1bac4be5a2a542372155f4224fcae8e5f847ba87a8029d9dad1')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/${pkgname%-git}/${pkgname%-git}-linux"
+ cd "${pkgname%-git}/${pkgname%-git}-linux"
mv README.md readme.md
}
build() {
- cd "$srcdir/${pkgname%-git}/${pkgname%-git}-linux"
- python -m build --wheel --no-isolation
+ cd "${pkgname%-git}/${pkgname%-git}-linux"
+ GIT_DIR='.' python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${pkgname%-git}/${pkgname%-git}-linux"
+ cd "${pkgname%-git}/${pkgname%-git}-linux"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 ../img/brightness.svg \