summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstrata2015-07-06 06:46:20 +1000
committerstrata2015-07-06 06:46:20 +1000
commit92420f7dbd29190a5bcafcada9b3a9caaec306c5 (patch)
tree42e284a604b9e902fd74acc94f9b0b49669ed636
downloadaur-92420f7dbd29190a5bcafcada9b3a9caaec306c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
-rw-r--r--brightness.run2
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f5ae7db083c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brightness-git
+ pkgdesc = Brightness Controller - allows you to control brightness of primary and secondary display
+ pkgver = 20140522
+ pkgrel = 1
+ url = http://github.com/lordamit/Brightness
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = python2
+ depends = wxpython
+ depends = wxgtk
+ depends = python2-pyside
+ source = brightness.run
+ md5sums = 6a99d9ba7e08f57d3614c63654cadcb8
+
+pkgname = brightness-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8987d15d9078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: strata <strata@dropswitch.net>
+pkgname=brightness-git
+pkgver=20140522
+pkgrel=1
+pkgdesc="Brightness Controller - allows you to control brightness of primary and secondary display"
+arch=('any')
+url="http://github.com/lordamit/Brightness"
+license=('GPLv3')
+depends=('python2' 'wxpython' 'wxgtk' 'python2-pyside')
+makedepends=('git')
+source=('brightness.run')
+md5sums=('6a99d9ba7e08f57d3614c63654cadcb8')
+
+_gitroot='https://github.com/lordamit/Brightness'
+_gitname='Brightness'
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ #
+ # BUILD HERE
+ #
+
+ sed -i 's;#!/usr/bin/python;#!/usr/bin/python2;' src/init.py
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/lib/brightness
+ cp -r ${srcdir}/${_gitname}-build/src/* ${pkgdir}/usr/lib/brightness
+ install -m 755 ../brightness.run ${pkgdir}/usr/bin/brightness
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/brightness.run b/brightness.run
new file mode 100644
index 000000000000..78d1b8a5d1ec
--- /dev/null
+++ b/brightness.run
@@ -0,0 +1,2 @@
+#!/bin/sh
+PATH=$PATH:/usr/lib/brightness /usr/lib/brightness/init.py "$@"