summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTuure2022-05-23 02:06:02 +0300
committerTuure2022-05-23 02:06:02 +0300
commitfa07e1ccf609ce85808b85c4fd480d78aeff81a2 (patch)
tree8e2a69e3b8b29ae668862564cfdff3b29d63fda8
parent00e04939ce81946d2fa373d8a3d4af48221c46c3 (diff)
downloadaur-fa07e1ccf609ce85808b85c4fd480d78aeff81a2.tar.gz
Fix source and update build (enable logind)
Package couldn't be retrieved from github due to issue explained here: https://github.blog/2021-09-01-improving-git-protocol-security-github/ brightnessctl build has changed since `configure` script was added. Enable systemd-logind in favor of configuring udev rules.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b6a562740b..f5b6d4a1e1e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = brightnessctl-git
pkgdesc = Lightweight brightness control tool
- pkgver = 0.4.r9.g4500f76
+ pkgver = 0.5.1.r17.gef49d47
pkgrel = 1
url = https://github.com/Hummer12007/brightnessctl
arch = i686
arch = x86_64
license = MIT
makedepends = git
- makedepends = pkg-config
provides = brightnessctl
conflicts = brightnessctl
- source = git://github.com/Hummer12007/brightnessctl
+ source = brightnessctl-git::git+https://github.com/Hummer12007/brightnessctl.git
sha256sums = SKIP
pkgname = brightnessctl-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 66f6a9bb003a..9f236bdb6cd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
-# Maintainer: Davide Depau <davide@depau.eu>
+# Contributor: smlb <smlbr01@gmail.com>
+# Contributor: Davide Depau <davide@depau.eu>
+# Maintainer: Tuure Piitulainen <tuure.piitulainen@gmail.com>
-_pkgname=brightnessctl
-pkgname=${_pkgname}-git
-pkgver=0.4.r9.g4500f76
+pkgname=brightnessctl-git
+pkgver=0.5.1.r17.gef49d47
pkgrel=1
pkgdesc="Lightweight brightness control tool"
arch=('i686' 'x86_64')
-url='https://github.com/Hummer12007/brightnessctl'
+url="https://github.com/Hummer12007/brightnessctl"
license=('MIT')
-makedepends=('git' 'pkg-config')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("git://github.com/Hummer12007/$_pkgname")
+makedepends=('git')
+provides=('brightnessctl')
+conflicts=('brightnessctl')
+source=("$pkgname::git+https://github.com/Hummer12007/brightnessctl.git")
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "$pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$_pkgname"
- make PREFIX=/usr
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr --enable-logind
+ make
}
package() {
- cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir" UDEVDIR=/usr/lib/udev/rules.d install
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
}