summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHong Shick Pak2019-09-04 21:07:05 -0700
committerHong Shick Pak2019-09-04 21:07:05 -0700
commit94e9eb75ed9f2c54863964b29b4c3f379122050b (patch)
tree2fd8dca3d72498038a9b745ff3475ee6d0f952b5
downloadaur-94e9eb75ed9f2c54863964b29b4c3f379122050b.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfdeddd7aaf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = brightnessztl
+ pkgdesc = A CLI to control device backlight
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://github.com/hspak/brightnessztl
+ arch = x86_64
+ license = MIT
+ makedepends = zig-git
+ provides = brightnessztl
+ conflicts = brightnessztl
+ source = https://github.com/hspak/brightnessztl/archive/v0.1.tar.gz
+ sha256sums = ada71f5c0181a979855d50b2b61eb85e780aae88b5421ceefb689d1e04b0049d
+
+pkgname = brightnessztl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ba351d9f605
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Hong Shick Pak <hong@hspak.com>
+
+pkgname=brightnessztl
+pkgver=0.1
+pkgrel=1
+pkgdesc="A CLI to control device backlight"
+arch=('x86_64')
+url="http://github.com/hspak/brightnessztl"
+license=('MIT')
+depends=()
+makedepends=('zig-git')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("https://github.com/hspak/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('ada71f5c0181a979855d50b2b61eb85e780aae88b5421ceefb689d1e04b0049d')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ zig build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ # binary
+ install -D -m 0755 "zig-cache/bin/brightnessztl" "${pkgdir}/usr/bin/brightnessztl"
+
+ # license
+ install -D -m 0644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ft=sh syn=sh et