summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHong Shick Pak2019-09-04 21:40:43 -0700
committerHong Shick Pak2019-09-04 21:40:43 -0700
commited1c96be3183fd4d42288d459f506ecdf1a72a51 (patch)
tree122f7b1ba5456fe47957eaab5d723d530d777670
parent94e9eb75ed9f2c54863964b29b4c3f379122050b (diff)
downloadaur-ed1c96be3183fd4d42288d459f506ecdf1a72a51.tar.gz
add a check
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ba351d9f605..53c18f40e73e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,31 @@
pkgname=brightnessztl
pkgver=0.1
-pkgrel=1
-pkgdesc="A CLI to control device backlight"
+pkgrel=2
+pkgdesc="A CLI to control device backlight written in Zig"
arch=('x86_64')
-url="http://github.com/hspak/brightnessztl"
+url="https://github.com/hspak/brightnessztl"
license=('MIT')
depends=()
makedepends=('zig-git')
provides=("$pkgname")
conflicts=("$pkgname")
-source=("https://github.com/hspak/$pkgname/archive/v$pkgver.tar.gz")
+source=("https://github.com/hspak/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('ada71f5c0181a979855d50b2b61eb85e780aae88b5421ceefb689d1e04b0049d')
build() {
cd "${pkgname}-${pkgver}"
-
zig build
}
-package() {
+check() {
cd "${pkgname}-${pkgver}"
+ zig-cache/bin/brightnessztl debug
+}
- # binary
+package() {
+ cd "${pkgname}-${pkgver}"
install -D -m 0755 "zig-cache/bin/brightnessztl" "${pkgdir}/usr/bin/brightnessztl"
-
- # license
install -D -m 0644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}