summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMa Jiehong2015-06-09 22:32:26 +0200
committerMa Jiehong2015-06-09 22:32:26 +0200
commit6dcc0b20f036bf02776dc49d6f25902526336533 (patch)
treec368aab2a27baccc34cd6ddacd5d27e6ea74495d
downloadaur-6dcc0b20f036bf02776dc49d6f25902526336533.tar.gz
Import brise-extra to AUR 4
-rw-r--r--.SRCINFO25
-rw-r--r--Makefile.patch10
-rw-r--r--PKGBUILD33
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d87134832b3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 9 20:30:57 UTC 2015
+pkgbase = brise-extra
+ pkgdesc = Rime schema repository with extra methods installed (array30, scj6, stenotype, traditional wubi)
+ pkgver = 0.35
+ pkgrel = 2
+ url = http://code.google.com/p/rimeime/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = librime>=1.2
+ provides = librime-data
+ provides = brise
+ conflicts = librime<1.2
+ conflicts = ibus-rime<1.2
+ conflicts = brise
+ source = git+https://github.com/lotem/brise.git#tag=brise-0.35
+ source = Makefile.patch
+ sha512sums = SKIP
+ sha512sums = fb50ba9f6d5ea8aa81be8f1823040a175809e844e4426228188749ef178dec496aa44571cd5980845bc5392a1c1476871c676f32ba3ab917ddc1c01008ee6018
+
+pkgname = brise-extra
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..b8fb006d837d
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,10 @@
+--- Makefile 2013-12-26 10:40:40.000000000 +0100
++++ ../../Makefile 2014-01-19 09:53:07.393783912 +0100
+@@ -18,6 +18,7 @@
+ @cp symbols.yaml ${DATA}
+ @cp preset/*.yaml ${DATA}
+ @cp supplement/*.yaml ${DATA}
++ @cp extra/*.yaml ${DATA}
+ rime_deployer --build ${DATA}
+
+ essay:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d116a87a57ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jiehong Ma <email@majiehong.com>
+# From: PKGBUILD of community/brise
+
+pkgname=brise-extra
+pkgver=0.35
+pkgrel=2
+pkgdesc="Rime schema repository with extra methods installed (array30, scj6, stenotype, traditional wubi)"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/rimeime/"
+license=('GPL3')
+depends=()
+makedepends=('cmake' 'git' 'librime>=1.2')
+provides=('librime-data' 'brise')
+conflicts=('librime<1.2' 'ibus-rime<1.2' 'brise')
+source=("git+https://github.com/lotem/brise.git#tag=brise-$pkgver" "Makefile.patch")
+sha512sums=('SKIP'
+ 'fb50ba9f6d5ea8aa81be8f1823040a175809e844e4426228188749ef178dec496aa44571cd5980845bc5392a1c1476871c676f32ba3ab917ddc1c01008ee6018')
+
+prepare()
+{
+ cd brise/
+ patch Makefile ../Makefile.patch
+}
+
+build() {
+ cd brise
+ make
+}
+
+package() {
+ cd brise
+ make DESTDIR="$pkgdir" install
+}