summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2017-11-02 12:29:33 +0100
committerFrederic Bezies2017-11-02 12:29:33 +0100
commitd5b6778d8b09c09c43a6d9ea704099387c1d492e (patch)
treea17228456708acd4dee48ced10d81cdfbb837977
parent4d60c3a71ac19dba579a611bd4bfaec0a6d5a7ff (diff)
downloadaur-d5b6778d8b09c09c43a6d9ea704099387c1d492e.tar.gz
November 2nd, 2017 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c77daf791c65..32b3a95aa9dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 24 10:03:11 UTC 2017
+# Thu Nov 2 11:29:19 UTC 2017
pkgbase = brisk-menu-git
pkgdesc = Modern, efficient menu for the MATE Desktop Environment - git version
- pkgver = v0.4.5.r24.gc2c3e58
+ pkgver = v0.4.5.r50.g3650121
pkgrel = 1
url = https://github.com/solus-project/brisk-menu
arch = i686
@@ -10,7 +10,13 @@ pkgbase = brisk-menu-git
groups = mate
license = GPL2
makedepends = gnome-common
+ makedepends = gettext
+ makedepends = itstool
+ makedepends = vala>=0.36
+ makedepends = meson
+ makedepends = ninja
depends = mate-panel
+ depends = libnotify
optdepends = mozo: for menu edition
optdepends = menulibre: for menu edition
provides = brisk-menu
diff --git a/PKGBUILD b/PKGBUILD
index 6406968286ac..2c67a7cbb8c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=brisk-menu-git
_gitname=brisk
-pkgver=v0.4.5.r24.gc2c3e58
+pkgver=v0.4.5.r50.g3650121
pkgrel=1
pkgdesc='Modern, efficient menu for the MATE Desktop Environment - git version'
arch=('i686' 'x86_64')
url='https://github.com/solus-project/brisk-menu'
license=('GPL2')
groups=('mate')
-depends=('mate-panel')
-makedepends=('gnome-common')
+depends=('mate-panel' 'libnotify')
+makedepends=('gnome-common' 'gettext' 'itstool' 'vala>=0.36' 'meson' 'ninja' )
optdepends=('mozo: for menu edition'
'menulibre: for menu edition')
options=('!libtool' '!emptydirs')
@@ -21,30 +21,21 @@ source=(git+https://github.com/solus-project/brisk-menu.git)
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/brisk-menu"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/brisk-menu"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/brisk-menu"
-
- autoreconf -i
- intltoolize
-
- ./configure \
- --prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib/${pkgname}
-
- make
+ cd "$srcdir/brisk-menu"
+ meson --buildtype plain build --prefix=/usr
+ ninja -C build -j$(($(getconf _NPROCESSORS_ONLN)+1))
}
package() {
- cd "$srcdir/brisk-menu"
-
- make DESTDIR="${pkgdir}" install
+ cd "$srcdir/brisk-menu"
+ DESTDIR="$pkgdir" ninja -C build install
}
+
+