summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorninioArtillero2022-11-25 20:24:24 -0600
committerninioArtillero2022-11-25 20:24:24 -0600
commit76010cf6d8f8cea8b556c89c653c51fe4476c36f (patch)
tree1bb2248d40afbf338cb6f0f04f0d463fcaaee28b
parent623c067a0a20ec37d43822bcfbca9a4a96050057 (diff)
downloadaur-brittany.tar.gz
update version and use commit hash to source from tag
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b912b9eecf1..8ab034e251c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = brittany
- pkgdesc = Haskell source code formatter
- pkgver = 0.13.1.1
+ pkgdesc = Haskell source code formatter (static)
+ pkgver = 0.13.1.2
pkgrel = 1
url = https://github.com/lspitzner/brittany
arch = x86_64
license = AGPL3
makedepends = git
makedepends = stack
- source = git+https://github.com/lspitzner/brittany#commit=4d064db674203626fe5011d10874fcbc335ec9b1
+ source = git+https://github.com/lspitzner/brittany.git?signed#tag=434f9f8e49b847ef3e648672c5564b6dd0d3be67
b2sums = SKIP
pkgname = brittany
-
diff --git a/PKGBUILD b/PKGBUILD
index 6e6cbac55699..0d860d4ae772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,27 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Maintainer: Xavier Gongora <ixbalanque@protonmail.ch>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
# Contributor: Wolfgang Popp <mail@wolfgang-popp.de>
# Contributor: Tharre <tharre3@gmail.com>
# Contributor: Damien Flament <damien.flament at gmx dot com>
pkgname=brittany
-pkgver=0.13.1.1
+pkgver=0.13.1.2
pkgrel=1
-pkgdesc='Haskell source code formatter'
+pkgdesc='Haskell source code formatter (static)'
arch=(x86_64)
url='https://github.com/lspitzner/brittany'
license=(AGPL3)
makedepends=(git stack)
-source=("git+$url#commit=4d064db674203626fe5011d10874fcbc335ec9b1") # tag: 0.13.1.1
+_tag=434f9f8e49b847ef3e648672c5564b6dd0d3be67 # git rev-parse $pkgver
+source=("git+$url.git?signed#tag=$_tag")
b2sums=('SKIP')
+pkgver() { # prevents accidentally bumping pkgver without updating _tag as well
+ cd "$pkgname"
+ git describe --tags | sed 's/^v//' # get version tag and remove the first 'v' in the head if present
+}
+
+
build() {
cd $pkgname
stack build